HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Spamsnake Baruwa - Howto upgrade? (http://www.howtoforge.com/forums/showthread.php?t=51567)

normanu 22nd February 2011 12:39

Spamsnake Baruwa - Howto upgrade?
 
The new version of Baruwa is out version 1.0.2
As there are still some functions broken in the 1.0.1 I'd like to upgrade.
But in the howto custom versions where included so just doing a dpkg -i doesn't work with the new packages.

How can I upgrade to the newest version ?


And question 2, the fuzzy-cleanmysql cronjob doesn't work it gives a 100% cpu load but does nothing and keeps running forever until you kill it.
All configuration parameters where entered correctly.

Anyone having it working ?

itsnedkeren 22nd February 2011 13:44

I would also like to know howto upgrade Baruwa to the latest version :)

Regarding the /usr/sbin/fuzzy-cleanmysql script, I'm also having 100% cpu usage and it doesn't seem to complete it.

itsnedkeren 22nd February 2011 19:25

Are these the packages you're trying to use?

http://topdog-software.com/oss/baruwa/1.0.2/deb/

normanu 22nd February 2011 19:30

yes that are the ones.....

itsnedkeren 22nd February 2011 19:55

Quote:

Originally Posted by normanu (Post 251915)
yes that are the ones.....

Cool, I'll snapshot my server and try to install.

itsnedkeren 22nd February 2011 20:24

Quote:

Originally Posted by itsnedkeren (Post 251916)
Cool, I'll snapshot my server and try to install.


That didn't work, no :(

We'll have to wait for the experts on this one!

itsnedkeren 22nd February 2011 21:05

I think I have the recipe now :)

Prerequisites:

1) Backup /usr/share/pyshared/baruwa/settings.py
2) Follow below

#cd /usr/src
#rm baruwa-doc_1.0.1-1_all.deb baruwa_1.0.1-1_all.deb
# wget http://topdog-software.com/oss/baruw....0.2-1_all.deb
#wget http://topdog-software.com/oss/baruw....0.2-1_all.deb
#gdebi baruwa*.deb <- SELECT NO TO DATABASE CONFIG!!
#reboot
#cd /usr/src/
#ln -s /opt/MailScanner-4.81.4-1/ /opt/MailScanner
#./mailscanner.sh
#/etc/init.d/mailscanner start
#/etc/init.d/postfix start

3) Copy your backed up "settings.py" to /usr/share/pyshared/baruwa

4) Reboot (might not be neccesary)

5) Profit? :)

Disclaimer: This worked for me, but I do NOT guarantee it will work for you!

EDIT: Functions such as deleting an "Auth server" from a domain, still causes errors, but the AJAX errors seems to be solved.
Code:

AttributeError at /settings/auth/2/delete/

'NoneType' object has no attribute 'widget'

Request Method:        POST
Request URL:        http://mailgw.domain.tld/settings/auth/2/delete/
Django Version:        1.2.3
Exception Type:        AttributeError
Exception Value:       

'NoneType' object has no attribute 'widget'

Exception Location:        /usr/lib/pymodules/python2.6/django/forms/forms.py in _clean_fields, line 278
Python Executable:       
Python Version:        2.6.6
Python Path:        ['.', '', '/usr/lib/python2.6', '/usr/lib/python2.6/plat-linux2', '/usr/lib/python2.6/lib-tk', '/usr/lib/python2.6/lib-old', '/usr/lib/python2.6/lib-dynload', '/usr/local/lib/python2.6/dist-packages', '/usr/lib/python2.6/dist-packages', '/usr/lib/python2.6/dist-packages/PIL', '/usr/lib/pymodules/python2.6', '/usr/lib/pymodules/python2.6/gtk-2.0']
Server time:        Tue, 22 Feb 2011 15:13:49 -0500


Rocky 22nd February 2011 21:49

Why don't you guys just follow the upgrade section of the howto guide? It's right below the installation of Baruwa section. I'll check out the fuzzy script.

itsnedkeren 23rd February 2011 08:40

Quote:

Originally Posted by Rocky (Post 251923)
Why don't you guys just follow the upgrade section of the howto guide? It's right below the installation of Baruwa section. I'll check out the fuzzy script.


Thanks a lot Rocky!

I couldn't get it to work by following the upgrade instruction in the How-To, therefore I made above "fix" :)

normanu 23rd February 2011 09:03

Besides the fact that I didn't see the upgrade part untill now :)
I would like to be able to keep the install updated myself...

This howto won't be updated forever....


All times are GMT +2. The time now is 18:23.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.