HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   ISPConfig 2.2.37 on Ubuntu 10.10 (http://www.howtoforge.com/forums/showthread.php?t=51520)

datago 19th February 2011 01:07

ISPConfig 2.2.37 on Ubuntu 10.10
 
I've loaded 2 servers with this combination one has permission problems which are inconvenient but can be worked around. The second one produces the following error when I attempt to install ISPConfig2. Yes I have followed Falko's how-to for both machines.

htpasswd.c:101: error: conflicting types for 'getline'

/usr/include/stdio.h:661: note: previous declaration of 'getline' was here

make[2]: *** [htpasswd.o] Error 1

make[2]: Leaving directory `/root/install_ispconfig/compile_aps/apache_1.3.41/src/support'

make[1]: *** [build-support] Error 1

make[1]: Leaving directory `/root/install_ispconfig/compile_aps/apache_1.3.41'

make: *** [build] Error 2

ERROR: Could not make Apache

Any ideas??

falko 19th February 2011 18:06

Take a look at chapter 22 on http://www.howtoforge.com/perfect-se...ispconfig-2-p7

datago 19th February 2011 19:43

Yes I've made that change at line 671 as both getline and parseline.
getline dies much earlier in the compile
parseline produces the error as posted
I have tried without success changing the getline at line 661 to parseline
I've redownloaded another copy of ispconfig which as expected didn't make any difference either.

falko 21st February 2011 00:09

What's the output of
Code:

ls -l /bin/sh
?

datago 25th February 2011 22:17

when i run ls -l /bin/sh the result is /bin/sh -> bash

falko thanks for helping with this oddity!!

falko 26th February 2011 15:20

That's ok. What exactly did you change in /usr/include/stdio.h? Did oyu replace getline with parseline in line 671, or did you change anything in addition to that?

datago 26th February 2011 17:50

at line 671 changed getline to parseline
at line 661 have tried it as both getline and parseline - currently its getline after changing it to parseline just produced a different error i put it back as it was originally

I'm wondering if replacing the stdio.h file with the one from the other machine might make a difference just in case I have inadvertently made some other change to the non-working machine?

falko 27th February 2011 21:48

Just change line 671, no other lines.

datago 28th February 2011 16:46

Only changing line 671 produces the error as originally posted.

falko 1st March 2011 17:17

It was working for me when I tested it, but that was on an i386 system. Do you have a 32- or 64-bit system?


All times are GMT +2. The time now is 04:53.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.