HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   PHPMYADMIN not found or wrong link in the ISPConfig 3 (http://www.howtoforge.com/forums/showthread.php?t=51518)

vaio1 18th February 2011 21:24

PHPMYADMIN not found or wrong link in the ISPConfig 3
 
1 Attachment(s)
Hi guys,

maybe I have found a little error in the ispconfig layout. If I click at the connection database link button at the database management page, I am redirected at the http://dbserver.mydomain.com/phpmyadmin.

As described in the manual the phpmyadmin has been installed in the webserver and not in the dbserver.

So what happens?

vaio1 19th February 2011 10:57

The problem is within the Interface Config.

The default phpmyadmin link must be http://webserver.mydomain.com/phpmyadmin

At the moment the link is http://dbserver.mydomain.com/phpmyadmin ;)

Furthermore the phpmyadmin config file is wrong:

Code:


  GNU nano 2.2.4                    File: config.inc.php                                             

<?php
/**
 * Please, do not edit this file. The configuration file for Debian
 * is located in the /etc/phpmyadmin directory.
 */

// Load secret generated on postinst
include('/var/lib/phpmyadmin/blowfish_secret.inc.php');

// Load autoconf local config
include('/var/lib/phpmyadmin/config.inc.php');

// Load user's local config
include('/etc/phpmyadmin/config.inc.php');

// Set the default server if there is no defined
if (!isset($cfg['Servers'])) {
    $cfg['Servers'][1]['host'] = 'localhost';
}

$cfg['Servers'][1]['host'] = "dbserver.mydomain.com";

// Set the default values for $cfg['Servers'] entries
for ($i=1; (!empty($cfg['Servers'][$i]['host']) || (isset($cfg['Servers'][$i]['connect_type']) && $cf$
    if (!isset($cfg['Servers'][$i]['auth_type'])) {
        $cfg['Servers'][$i]['auth_type'] = 'cookie';
    }
    if (!isset($cfg['Servers'][$i]['host'])) {
        $cfg['Servers'][$i]['host'] = 'localhost';
    }
    if (!isset($cfg['Servers'][$i]['connect_type'])) {
        $cfg['Servers'][$i]['connect_type'] = 'tcp';
    }
    if (!isset($cfg['Servers'][$i]['compress'])) {
        $cfg['Servers'][$i]['compress'] = false;
    }
    if (!isset($cfg['Servers'][$i]['extension'])) {
        $cfg['Servers'][$i]['extension'] = 'mysql';
    }
}

Regards

Regards

vaio1 19th February 2011 11:23

Furthermore if a database is not enabled for the remote connection the phpmyadmin doesn't accept the requests.

If the DBServer is configured with the multiserver setup, the users permissions must be set with the host webserver.mydomain.com otherwise they cannot connect using the phpmyadmin software.

The workaround is enable them to using a remote connection and this is not a good idea at all. So why ispConfig doesn't set the right permission?

thanks

falko 19th February 2011 16:42

You can configure the phpMyAdmin link in ISPConfig's system settings.

vaio1 19th February 2011 19:56

Hi Falko,

anyway the databases can be read only if I select the remote access in the control panel. Is there a way to solve this problem?

thanks

falko 20th February 2011 23:02

Quote:

Originally Posted by mturillo (Post 251693)
Hi Falko,

anyway the databases can be read only if I select the remote access in the control panel. Is there a way to solve this problem?

thanks

Are the databases installed on a different server than phpMyAdmin?

falko 20th February 2011 23:02

Quote:

Originally Posted by Bashewa (Post 251704)
Hi Ive installed ISPconfig3 on Debian Squeeze on a dedicated server with 3 available IP's and everything works fine except for phpmyadmin.

When I create a database I can access phpmyadmin from the ISPconfig panel by clicking the connection to phpmyadmin from the sites/database interface, but I cannot login with the username and password I just set up.


I can login to mysql server from command line by doing

mysql -u root -p

so mysql server is running

remote access is also ticked

Ive set phpmyadmin interface on ISPconf to http://xx.xx.149.228/phpmyadmin/ which I can open but wont except username and password ( #1045 Cannot log in to the MySQL server
)

Any ideas how to start fault tracing?:confused:

Please open a new thread.

dvancamp 21st February 2011 04:13

Sorry to jump in
 
I'm experiencing the same issue as mturillo on the multi-server setup outlined in the manual. PhpMyAdmin ends up on the webserver and is configured to connect to the localhost while the ISPConfig interface is creating client's databases on the dedicated database server.

I manually added my db host to /etc/phpmyadmin/config.inc.php like mturillo but you still run into the problem of clients having to allow remote access to the entire internet or knowing the IP address of your main ISPConfig server.

My first instinct was to change the defaults in the interface form (ispconfig/interface/web/sites/form/database.tform.php) and prefill the checkbox and IP address. Obviously kind of a hack that wouldn't survive upgrades.

I see in that same database.tform.php script it pulls the database server names out of the configuration. Would it make sense to automatically grant remote access to nodes configured as webservers? Leaving the remote access checkbox and IPs to servers outside of ISPConfig control...


All times are GMT +2. The time now is 05:42.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.