HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   ispconfig3 + bind9 on centos 5.5 i386 (http://www.howtoforge.com/forums/showthread.php?t=51458)

stinson 15th February 2011 22:02

ispconfig3 + bind9 on centos 5.5 i386
 
Hi, I've done the perfect server setup on Centos 5.5 i386. I know that the howto is for x86_64 archs but as I said my Centos is i386 and I just want to try. Of course, I changed amd64 packages to i386 packages.

Now, I have ispconfig3 installed and works fine, I can send mails, create and use ftp accounts..etc. But when I try to add a dns zone, ispconfig doesn't write neither on /var/named/chroot/etc/named.conf nor on /var/named/chroot/etc/named.conf.local and commands like nslookup, ping, etc. don't recognize names. In /etc/resolv.conf, I have
Code:

nameserver 127.0.0.1
Hope you can help me! Thanks! ;)

falko 16th February 2011 16:36

Please try
Code:

nameserver 8.8.8.8
nameserver 8.8.4.4

instead in your resolv.conf.

stinson 16th February 2011 17:52

Ok, but google won't recognize my local zones... I supose I had to tell system to ask to my own dns server to ask about hostnames i've created. This is all on local network, i don't have any public domain or static ip, i'm just trying.. I should have said that, my fault..

falko 17th February 2011 17:19

Ok, then use
Code:

nameserver 8.8.8.8
nameserver 127.0.0.1

so that your system can look up real domains and your local domains.

Do you see any errors in ISPConfig's Monitoring module?

stinson 17th February 2011 20:43

Thanks, but I think the problem is not the resolv.conf. The problem is that ISPConfig doesn't write changes in DNS zones on named.conf. The control panel creates the hosts file (pri.*) but it doesn't add new zones to named.conf. I've copied exactly your named.conf (the howto's).

Everything is ok in the monitoring module. I see MyDNS server instead of Bind, is this ok?

Edit: Yeah! problem solved! ISPConfig saves DNS zones on /var/named/chroot/var/named/named.local, so I added the line:
Code:

include "/var/named/chroot/var/named/named.local";
to named.conf, restarted the server and now it works! Thank you falko for your help, now ispconfig seems to be better :D


All times are GMT +2. The time now is 11:35.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.