HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   jailkit problem (http://www.howtoforge.com/forums/showthread.php?t=51370)

pdga 10th February 2011 18:46

jailkit problem
 
Hi,

I have setup a multiserver setup on Debian Squeeze, ispconfig 3.0.3.2 and jailkit 2.13. It works. But when I add a shell user, his shell is /bin/false, so the user can't login. If I change to /bin/bash, it works. Is it a bug ? Where can I check the shell added by ispconfig in /etc/passwd ?

/edit : the user is not chrooted, I can browse the / filesystem.
/edit2 : I have installed jailkit by hand with configure/make/make install, I didn't see that there is a debian way now.

Thanks.

till 11th February 2011 11:52

Quote:

Originally Posted by pdga (Post 250790)
If I change to /bin/bash, it works. Is it a bug ?

There is a config problem on your system and not a bug. About which user do you talk, the web user has to be set to /bin/false as he may not login by ssh and there is a second user with the same uid that is set to the jailkit hell. That you can see all directories is vcaused by setting the shell to /bin/bash

Quote:

Where can I check the shell added by ispconfig in /etc/passwd ?
in /etc/passwd

Please check the ispconfig monitor if there are any jobs listed in the jobqueue and if ther are any errors in the sytem log.

pdga 11th February 2011 17:51

thanks for your reply.

Quote:

Originally Posted by till (Post 250865)
About which user do you talk, the web user has to be set to /bin/false as he may not login by ssh and there is a second user with the same uid that is set to the jailkit hell. That you can see all directories is vcaused by setting the shell to /bin/bash

#tail -4 /etc/passwd
web5:x:1002:1003::/var/www/clients/client1/web5/./home/web5:/bin/false
web6:x:1003:1004::/var/www/clients/client3/web6/./home/web6:/bin/false
adm_xxxxxxx-ssh:x:1002:1003::/var/www/clients/client1/web5/./home/adm_gatouillat-ssh:/bin/false
adm_yyyyyyy-ssh:x:1003:1004::/var/www/clients/client3/web6/./home/adm_handball-ssh:/bin/false

the adm* users should have the jk shell /usr/sbin/jk_chrootsh ?




Quote:


Please check the ispconfig monitor if there are any jobs listed in the jobqueue and if ther are any errors in the sytem log.
no job in the queue.

I just create another user and I have some errors in cron.log. I will check that first.

/edit : I made a symlink /var/www to /srv/www, it seems symlink is the problem. I will correct the paths and check again


All times are GMT +2. The time now is 01:17.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.