HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   FTP cannot login, lots of warnings in ISPconfig too (http://www.howtoforge.com/forums/showthread.php?t=51353)

talkingnews 10th February 2011 01:14

FTP cannot login, lots of warnings in ISPconfig too
 
Right now, my website it up, my ispconfig can be access, and I can ssh to the vps server. But ftp won't connect. Waits for welcome message, then nothing ever happens. All accounts.

Restarted with service pure-ftpd-mysql restart
Nothing
Rebooted whole VPS. Nothing.

Rebooted router to get a fresh IP in case it was some weird banning thing.
Nothing.

This has happened before, but I didn't do anything, and next day it had cleared itself.

What I DID notice was errors suddenly in ispconfig like

Code:

Notice: Undefined index: on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140 Notice: Undefined index: sites:on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140 Notice: Undefined index: sites:ftp_user:on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140 Notice: Undefined variable: wb in /usr/local/ispconfig/interface/lib/app.inc.php on line 187
I've read a few threads about checking the DB - repaired all ispconfig and mysql tables, all were OK except for:

mysql.general_log check Error You can't use locks with log tables.
mysql.slow_log check Error You can't use locks with log tables.

Does anyone know how I can get back into my ftp?

till 10th February 2011 10:47

To fix the php notices, please set the correct error_reporting level in the php.ini file(s) and rstart apache:

error_reporting = E_ALL & ~E_NOTICE

Regarding the FTP issue, please post the output of:

cat /proc/user_beancounters

talkingnews 10th February 2011 12:52

Quote:

Originally Posted by till (Post 250757)
To fix the php notices, please set the correct error_reporting level in the php.ini file(s) and rstart apache:

error_reporting = E_ALL & ~E_NOTICE

Ah, that was just me trying to find a way of getting apache to show me errors.
Didn't work anyway, so changed it back now.

Quote:

Originally Posted by till (Post 250757)
Regarding the FTP issue, please post the output of:
cat /proc/user_beancounters

No such file, searched the whole filesystem. And then this forum.
It appears this has something to do with VPS, and I'm on a VPS, but I don't run it. Could it be something to do with the host machine then?

talkingnews 10th February 2011 13:00

Quote:

Originally Posted by dfgd456fg45 (Post 250772)
some times when cookies are turned off or does not have the qualifications for login,some one can not login into the account.

login with firefox and let the cookies be turned on.

Cookies and Firefox in FTP? That's a new one for me!

I'm using filezilla as my ftp client, but was also using pspad. Both are working fine this morning. Nothing to do with browsers, this is FTP.

nababan 22nd March 2011 20:27

i am install pure-ftpd-mysql on debian and cannot login via filezilla.

falko 23rd March 2011 16:50

Which guide (URL) did you use?

Did you try both active and passive transfers in your FTP client?

Do you have any error messages that you can share with us?

nababan 23rd March 2011 18:16

Quote:

Originally Posted by falko (Post 253850)
Which guide (URL) did you use?

Did you try both active and passive transfers in your FTP client?

Do you have any error messages that you can share with us?

I am using this guide: http://www.howtoforge.com/pureftpd_m...irtual_hosting

I don't know about both active and passive transfers in FTP client
Could you explain to me?

Sorry, i am just a newbie on UNIX/Linux Debian :)

falko 24th March 2011 15:31

What Debian version do you use?

You can configure your FTP client to use active or passive mode for an FTP connection. I suggest you try both. If one succeeds while the other does not, it's most likely a firewall problem.

nababan 24th March 2011 17:07

Quote:

Originally Posted by falko (Post 253930)
What Debian version do you use?

You can configure your FTP client to use active or passive mode for an FTP connection. I suggest you try both. If one succeeds while the other does not, it's most likely a firewall problem.

I use Debian 6 Squeeze on Virtual Private Server wit OpenVZ

falko 25th March 2011 15:27

Please try chapter 20.1 from http://www.howtoforge.com/perfect-se...ispconfig-3-p6


All times are GMT +2. The time now is 17:33.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.