HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Virtual Users+Postfix+Courier+CentOS problem telnet localhost 25 (http://www.howtoforge.com/forums/showthread.php?t=51221)

stinson 2nd February 2011 00:19

Virtual Users+Postfix+Courier+CentOS problem telnet localhost 25
 
Hi! I'm trying to setup Postfix+Courier on my CentOS 5.5 server with the howto:
http://howtoforge.com/virtual-users-...ysql-centos5.1

I connect to pop3 (telnet localhost pop3) and it works fine but when I type the command "telnet localhost 25" i can see something like:
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.

Then the only thing I can do is to close the console. I tried to type ehlo localhost without result and also tried quit, with the same (no) result.

I hope you could help me.
Sorry about my (limited) english :S

wayner 2nd February 2011 15:11

You are connected to your SMTP Server over telnet, you can now test the server you have to send commandos to him for this.

For example
type:

EHLO yourdomain.com

When you do
AUTH LOGIN

you could even do a login and send a mail over it.

Abit descriped here:
http://technet.microsoft.com/en-us/l...EXCHG.65).aspx

stinson 2nd February 2011 17:38

Thanks for your reply. I typed EHLO mydomain.net, EHLO server.mydomain.net, EHLO localhost, AUTH LOGIN... and nothing happens.

I also tried: o myserver.mydomain.net on telnet prompt and this is what I could see:

telnet: connect to address 172.16.xxx.xxx: Connection refused
telnet: Unable to connect to remote host: Connection refused

The smtp is listening and both iptables and selinux ar off..what can I do? Thanks

wayner 2nd February 2011 18:50

Strange is that with quit you dont get a '221 Bye'. Sounds like a faulty postfix, probably something gone wrong when recompiling it with quota ... just a thought.

stinson 2nd February 2011 22:01

Hey! It's me again. I solved the problem. Well, not exactly... I have to say that I don't know which the problem was, I restarted the howto, recompiled postfix, etc.. and now it works... But I have another problem:

I tried to install squirrelmail with the howto http://www.howtoforge.com/virtual-us...-5.3-x86_64-p5

and when I type the username and password and press login in Squirrelmail an error appears
ERROR: Connection dropped by IMAP server.

In the maillog I see:

Code:

Feb  2 20:55:29 server imapd: Connection, ip=[::ffff:127.0.0.1]
Feb  2 20:55:29 server imapd: LOGIN FAILED, user=postmaster@mydomain.net, ip=[::ffff:127.0.0.1]
Feb  2 20:55:29 server imapd: authentication error: Input/output error

I've installed Thunderbird and fails too. Any suggestion?

falko 3rd February 2011 14:47

Is postmaster@mydomain.net a valid virtual account? I guess it interferes with the postmaster system user.

stinson 3rd February 2011 17:27

I've created a new user (user1) and the error persists... Maybe I have to recompile courier packages too..

Edit:
Nothing. I've recompiled courier packages, with more recent versions, but it still doesn't work. I've tried to send an email with telnet connection..and this is what I could see:

220 server.mydomain.net ESMTP Postfix
auth login
334 VXNlcm5hbWU6
base64_username
334 UGFzc3dvcmQ6
base64_pwd
535 5.7.0 Error: authentication failed: generic failure

maillog:

Feb 3 17:52:07 server postfix/smtpd[24194]: connect from localhost.localdomain[127.0.0.1]
Feb 3 17:53:04 server postfix/smtpd[24194]: warning: SASL authentication failure: could not verify password
Feb 3 17:53:04 server postfix/smtpd[24194]: warning: localhost.localdomain[127.0.0.1]: SASL LOGIN authentication failed: generic failure

stinson 3rd February 2011 20:50

I've tried to send an email between two same-domain users trought telnet and without AUTH LOGIN and it works. Seems to be a problem with sasl authentication. Is there an easy method to disable it and check Squirrelmail, Thunderbird..etc..?

What could be wrong? Thanks for your answers

falko 4th February 2011 15:48

First, make sure you authenticate with full email addresses, not just with the local part (the part in front of @). Also, please make sure that the local part does not exist as a system user in /etc/passwd or in /etc/aliases.

stinson 4th February 2011 17:30

Ok, I authenticate with full email addresses and there's not user1 on /etc/aliases... I've tried with another user and with non-encrypted passwords but still doesn't work. Do I need to configure DNS server or something that is not mentioned in the howto?

Edit: I don't know if this is important but every time I restart courier-authlib I see this on /var/log/maillog:
Feb 4 17:42:05 server authdaemond: stopping authdaemond children
Feb 4 17:42:05 server authdaemond: modules="authmysql", daemons=5
Feb 4 17:42:05 server authdaemond: Installing libauthmysql
Feb 4 17:42:05 server authdaemond: Installation complete: authmysql


All times are GMT +2. The time now is 02:01.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.