HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Mailfilter folders / files not created (http://www.howtoforge.com/forums/showthread.php?t=51171)

James A 28th January 2011 13:33

Mailfilter folders / files not created
 
Hi, we have been using ISPConfig successfully for about a year. Recently we found that adding auto responders / custom mail filters stopped working as the required files and directories weren't being created wasn't (we were running V3.0.1.6 at the time).

Since finding the issue we upgraded to 3.0.3.2 believing this may fix the issue. Unfortunately it didn't so we started to look into it in a lot greater detail.

First thing we found after enabling debug was that the job queue had backed up with the .ispconfig_lock file being present. We manually deleted this, however this was recreated everytime server.sh ran and no job progress occurred.

As we had created numerous jobs ourselves when testing the autoresponder we decided the most appropriate thing was to try and clear the job queue. There were no records in the sys_remoteuser and we followed earlier advice to clear the sys_datalog which then cleared the queue and allowed server.sh to run successfully (or so it appears, no more permanent .ispconfig_lock file).

Unfortunately though, we are still not able to create the autoresponder files from the GUI. and are having to manually create the files by copying the autoresponder.master and creating a vacation.message in order to get it working where required. It appears that any attempt to create files under the mailfilters directory is failing.

For further detail, we are using courier-imap with the maildrop mailfilter syntax configured. From what we understand, it's the maildrop plugin that creates these files / folders. There is a symlink in the plugins-enabled folder for this.

Final things to note:
We don't appear to get any update jobs processed by server.sh and they are not appearing in the job queue. Server.sh just responds with no updates even after updates have clearly been made.

Even with debug enabled we don't appear to get any error or warning messages, and apart from this issue the servers appear to work fine.

Any help would be gratefully appreciated.

manticore01 28th January 2011 16:13

Same Issue
 
Hi James

I seem to be experiencing the same issue aswell, its as if the maildrop plugin isnt firing as this is what creates the mailfilter directories if im not mistaken.

James A 28th January 2011 17:17

Hi Manticore

Yeah this is a really weird one although I'm sure there's an easy fix. No doubt when Till or Falco get a chance to read this post they'll point us in the right direction.:)

till 29th January 2011 15:02

@James: Most likely your problem is not related to mail filters. I guess that your system daemon is not writing changes at all at the moment. Please check if other changes like creating a new website gets written to disk.


@manticore: Please check that you reaally use courier. In almost al current poerfect setup guides we use dovecot and not courier.

I dont think that there is a problem at all, the folders that you think are missing are only used by courier pop3 / imap daemon. So on all other systems that use dovecot, thes efolders are not there and shall not be there as dovecot stores the rules in the .sieve file which is in the maildir an not a separate mail

James A 31st January 2011 10:39

Hi Till

As suggested I tried creating a website and your assumption was correct, no files / folders were created in the var/www/clients directory. Looking at the job queue nothing appears to have been added and no updates found when server.sh ran.

It is probably worth noting if I create a new email address then I do get folders created under the var/vmail/ folder.

So if the problem is that the system daemon isn't writing changes how do I fix that (apologies if this is a stupid question)?

Thanks

James A 10th March 2011 17:09

Hi All

This is still a problem for me and I would really appreciate some help.

If the issue is as Till suggests, that the system Daemon isn't writing changes at all at the moment how do I get it going again. Please note I'm assuming this is correct as I can't create a new website but I can create email accounts under var/vmail.

Any help would be appreciated :confused:

till 10th March 2011 17:12

Quote:

but I can create email accounts under var/vmail.
Email accounts get created automatically by postfix and maildrop or deliver when a email arrives, this is no indication that any config files get written to disk.

So the jobqueue is empty at the moment?

James A 10th March 2011 17:14

Yup, no jobs at present

till 10th March 2011 17:25

Please edit the root crontab by running the command:

crontab -e

and comment out the server.sh cronjob line by adding a # in the first line. Then create a new website or email mailbox in ispconfig and check the ispconfig monitor, a item must show up in the jobqueue then.

James A 10th March 2011 17:39

Hi Till

I have just run a few tests, adding an autoresponder to a mailbox and then checking the job queue and confirm they aren't being added. I also checked the system-log which simply shows:

2011-03-10 16:28 srv.xyz.com Debug Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2011-03-10 16:28 srv.xyz.com Debug No Updated records found, starting only the core.
2011-03-10 16:28 srv.xyz.com Debug Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

so it doesn't look as though I'm just being slow and the job is processing.

What does happen is the change appears to get written to the ISPConfig database as the change is shown when I go back to the email account in question.


All times are GMT +2. The time now is 11:52.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.