HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Tips/Tricks/Mods (http://www.howtoforge.com/forums/forumdisplay.php?f=29)
-   -   Problem Updating and Uploading to Wordpress website on ISPConfig3 - Fedora 13 (http://www.howtoforge.com/forums/showthread.php?t=51163)

MrCompTech 27th January 2011 22:36

Problem Updating and Uploading to Wordpress website on ISPConfig3 - Fedora 13
 
I actually resolved this issue. I thought I would post the results because it took most of my day to get this figured out! Maybe posting this here will save others some time.

I have joomla sites on the same server and they run without any problems.

The server is on my local 100MB LAN and there is one connection from the router to the Internet through a cable modem.

The settings for the website are:
DOMAIN:
  • CGI - unchecked
  • SSI - unchecked
  • SuEXEC - checked
  • Own Error-Documents - unchecked
  • Auto-Subdomain - unchecked
  • SSL - unchecked
  • PHP - Fast-CGI
  • Active - Checked
OPTIONS:
  • Linux User - web33
  • Linus Group - client1
  • Allow Override - All
  • PHP open_base_dir -:/var/www/clients/client1/web33/web:/var/www/clients/client1/web33/tmp:/var/www/hyper-facebook-traffic-unleashed.com/web:/srv/www/hyper-facebook-traffic-unleashed.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin
  • Apache directives - (none)

While shelled in as 'root' run the command:
Code:

chown -R web33:client1 /var/www/clients/client1/web33/web
This ensures proper ownership of all folders on files, you must match the client? and web? group and owner to the file path.

More description of the problem and sysmptom:
I can FTP (FilaZilla) to upload unzipped themes and plugins to the Wordpress website.
I can use the Wordpress admin interface to install plugins from the web.
I can use the Wordpress admin interface to install themes from the web.
I can use the Wordpress admin interface to install plugins from zip files on my PC.
I can use the Wordpress admin interface to install themes plugins from zip files on my PC.

I cannot auto-update my Wordpress website.
When I try I get the error message: 'Could not create directory.: /web'

The image I am trying to upload is named hfbt.jpg and is 164KB.

I cannot add images to posts or pages when I try, I get the error message:
================================================== ========
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, info@hyper-facebook-traffic-unleashed.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Apache/2.2.17 (Fedora) Server at hyper-facebook-traffic-unleashed.com Port 80
================================================== ========
NOTE: if this site is using 'Own Error-Documents' then this error message will have error number 500 in it.

OK, now on to troubleshooting the problem...
I had another issue with Wordpress sites causing a lot of errors to be written to the error.log file. This made it difficult realize these were two different problems. After realixing there were at least two problems, I finally saw the error message for this problem.

Code:

[Thu Jan 27 15:14:15 2011] [warn] [client 192.168.1.151] mod_fcgid: HTTP request length 131484 (so far) exceeds MaxRequestLen (131072), referer: http://hyper-facebook-traffic-unleas...21&type=image&
After seeing this I uploaded a much smaller file 1.5kb and it uploaded just fine. So it is a file size issue, but on the WP upload screen it says "Maximum upload file size: 2MB". This limit must be set somewhere. In /etc/php.ini is has - "upload_max_filesize = 2M"

I Googled for:
Code:

+mod_fcgid +"HTTP request length"
And came up with -
On this page I searched for (Ctrl+F) and found 'HTTP - request length'

The Syntax of the directive is -
Quote:

FcgidMaxRequestLen bytes
So I:
  • logged into the ISPConfig3 admin console
  • went to 'Sites'
  • clicked on the name of the website
  • clicked on the 'Options' tab
  • In the 'Apache Directives' I entered:FcgidMaxRequestLen 2000000
I didn't want to wait a couple of minutes for cron to run the sever.sh script to update ISPConfig3 so I did it manually:

I knew the name of the file to update ISPConfg3 from other issues I dealt with and searched on this forum for.

From the shell prompt to find a file you may need to update the file database first by running
Code:

updatedb
Then to locate the file run
Code:

locate server.sh
Which revealed -
Code:

/usr/local/ispconfig/server/server.sh
To update the ISPConfig3 setting run this at the comand prompt as root -
Code:

/usr/local/ispconfig/server/server.sh
Then went back to the Wordpress Admin page and could now upload the image file for a page I was editing that previously failed to upload.

I checked the file size of the Wordpress update and found that it's compressed file size is over 2MB, so I changed the apache directive FcgidMaxRequestLen from 2000000 to 5000000.

Now I can update my Wordpress site from the admin panel!

To summarize, the default value for the 'HTTP Request length' which is 'FcgidMaxRequestLen' is only 131072 bytes. This is changed using the apache directive 'FcgidMaxRequestLen bytes' which can be done through the ISPConfig management console.

ivomendonca 28th January 2011 06:16

Wordpress 2.000.000 hits How to
 
!!Uau, MrCompTech this is very usefull.
I will facebook this now!!!
Twitt this NOW!!!


Quote:

Originally Posted by MrCompTech (Post 249770)
I actually resolved this issue. I thought I would post the results because it took most of my day to get this figured out! Maybe posting this here will save others some time.

I have joomla sites on the same server and they run without any problems.

The server is on my local 100MB LAN and there is one connection from the router to the Internet through a cable modem.

The settings for the website are:
DOMAIN:
  • CGI - unchecked
  • SSI - unchecked
  • SuEXEC - checked
  • Own Error-Documents - unchecked
  • Auto-Subdomain - unchecked
  • SSL - unchecked
  • PHP - Fast-CGI
  • Active - Checked
OPTIONS:
  • Linux User - web33
  • Linus Group - client1
  • Allow Override - All
  • PHP open_base_dir -:/var/www/clients/client1/web33/web:/var/www/clients/client1/web33/tmp:/var/www/hyper-facebook-traffic-unleashed.com/web:/srv/www/hyper-facebook-traffic-unleashed.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin
  • Apache directives - (none)

While shelled in as 'root' run the command:
Code:

chown -R web33:client1 /var/www/clients/client1/web33/web
This ensures proper ownership of all folders on files, you must match the client? and web? group and owner to the file path.

More description of the problem and sysmptom:
I can FTP (FilaZilla) to upload unzipped themes and plugins to the Wordpress website.
I can use the Wordpress admin interface to install plugins from the web.
I can use the Wordpress admin interface to install themes from the web.
I can use the Wordpress admin interface to install plugins from zip files on my PC.
I can use the Wordpress admin interface to install themes plugins from zip files on my PC.

I cannot auto-update my Wordpress website.
When I try I get the error message: 'Could not create directory.: /web'

The image I am trying to upload is named hfbt.jpg and is 164KB.

I cannot add images to posts or pages when I try, I get the error message:
================================================== ========
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, info@hyper-facebook-traffic-unleashed.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Apache/2.2.17 (Fedora) Server at hyper-facebook-traffic-unleashed.com Port 80
================================================== ========
NOTE: if this site is using 'Own Error-Documents' then this error message will have error number 500 in it.

OK, now on to troubleshooting the problem...
I had another issue with Wordpress sites causing a lot of errors to be written to the error.log file. This made it difficult realize these were two different problems. After realixing there were at least two problems, I finally saw the error message for this problem.

Code:

[Thu Jan 27 15:14:15 2011] [warn] [client 192.168.1.151] mod_fcgid: HTTP request length 131484 (so far) exceeds MaxRequestLen (131072), referer: http://hyper-facebook-traffic-unleas...21&type=image&
After seeing this I uploaded a much smaller file 1.5kb and it uploaded just fine. So it is a file size issue, but on the WP upload screen it says "Maximum upload file size: 2MB". This limit must be set somewhere. In /etc/php.ini is has - "upload_max_filesize = 2M"

I Googled for:
Code:

+mod_fcgid +"HTTP request length"
And came up with -
On this page I searched for (Ctrl+F) and found 'HTTP - request length'

The Syntax of the directive is -

So I:
  • logged into the ISPConfig3 admin console
  • went to 'Sites'
  • clicked on the name of the website
  • clicked on the 'Options' tab
  • In the 'Apache Directives' I entered:FcgidMaxRequestLen 2000000
I didn't want to wait a couple of minutes for cron to run the sever.sh script to update ISPConfig3 so I did it manually:

I knew the name of the file to update ISPConfg3 from other issues I dealt with and searched on this forum for.

From the shell prompt to find a file you may need to update the file database first by running
Code:

updatedb
Then to locate the file run
Code:

locate server.sh
Which revealed -
Code:

/usr/local/ispconfig/server/server.sh
To update the ISPConfig3 setting run this at the comand prompt as root -
Code:

/usr/local/ispconfig/server/server.sh
Then went back to the Wordpress Admin page and could now upload the image file for a page I was editing that previously failed to upload.

I checked the file size of the Wordpress update and found that it's compressed file size is over 2MB, so I changed the apache directive FcgidMaxRequestLen from 2000000 to 5000000.

Now I can update my Wordpress site from the admin panel!

To summarize, the default value for the 'HTTP Request length' which is 'FcgidMaxRequestLen' is only 131072 bytes. This is changed using the apache directive 'FcgidMaxRequestLen bytes' which can be done through the ISPConfig management console.


mjnet 12th February 2012 21:42

thank you sir!!!!! you're the fu**** MAN! :D:D:D

tradari 26th February 2012 02:37

ive been at this for 3 days now then i came accross your post

YOU ARE THE MAN!!!

i dont think i would have ever found that and in thre mean time i learnt where the log file was too

Cheers
Tradari
:):):):)

zephyrnet 2nd May 2012 22:30

Brilliant
 
Many thanks, saved me hours of head scratching. :)

Falko /Till
Can the next release of ispconfig3 make the default value slightly higher to avoid this symptom and save many a late night? Ive got to find time to watch Game of Thrones too you know :-)

Thanks again all.

xaver 4th May 2012 19:31

Hi,

i had this problem long ago.
I set the param in /etc/apache2/mods-enabled/fcgid.conf and added:
MaxRequestLen 15728640

Problem solved for all Webs

ergec 2nd July 2013 20:22

After 2 years and you are still F*CKN THE MAN OF THE DECADE YOU ARE AWESOME :D :D :D :D

Fernando Kosh 7th January 2014 01:07

Many thanks!
Very useful post.
Saved me hours of Googling, tests and etc...!!!
:)


All times are GMT +2. The time now is 04:49.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.