HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   jailkit locale/font/utf8 (http://www.howtoforge.com/forums/showthread.php?t=51047)

8omas 21st January 2011 14:23

jailkit locale/font/utf8
 
I installed the latest version of ISPconfig eith the jailkit.
All works fine. I can choose if a user will be 'jailed' or not, I can create sebsites, domains etc.

The only problem I have is with the locale of chrooted users in ssh. I am from Greece and I cannot see greek characters in the ssh environment of the 'jailed' user.

If I 'unjail' him I can see perfectly the greek characters.

Is anyone facing something similar?
Is there a solution for this?

My tries up to now:

I added in /etc/jailkit/jk_init.ini the following:

Code:

[fontconfig]
paths = /etc/fonts, /etc/console-tools/config, /etc/default/locale, /usr/lib/libfontconfig.so.1, /usr/lib/libfontconfig.so.1.3.0
includesections = fonts

[fonts]
directories = /usr/share/fonts

I also added the fontconfig and fonts in the ISPconfig of jailkit, but I have no luck so far.

till 21st January 2011 14:26

The jail is only created once per website when the first jailed user is added. So if you want to test your new settings, it might be nescessary to create a new website and then a new ssh user in that site.

8omas 21st January 2011 14:32

I already tried that. I'm sorry. I forgot to mention that I read almost every post in the forum, concerning jailkit.

8omas 21st January 2011 14:47

One more thing I noticed during my efforts.
When I pasted the above in /etc/jailkit/jk_init.ini and I updated the config of ispconfig (with php -q update.php) the /etc/jailkit/jk_init.ini was overwritten with the previous (clean) one (without my entries).

8omas 24th January 2011 23:05

1 Attachment(s)
One more 'evidence', in case someone can help.

In the attached image you can see the 'strange' greek characters. Those are written in the console. After saving this file, and opening the browser to see the page, all the greek characters as showing fine.

I think, this might be a font problem. Am I right?


All times are GMT +2. The time now is 16:25.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.