HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Configuring SSL certificate to website ISPConfig 3 (http://www.howtoforge.com/forums/showthread.php?t=50918)

rogeriosjr 12th January 2011 12:34

Configuring SSL certificate to website ISPConfig 3
 
Hello all!

I read ISPConfig 3 manual (5.4 How Do I Create An SSL Web Site?) and it works just for a Self-signed certificate and presents into my webclient browser that certificate was issued by "localhost.localdomain".

I follwed instructions to save a trusted certificate, but it does not work for me.

Can you help me to use this trusted certificate? Is there any other conf that I need to do into Apache or ISPConfig to solve this issue?

Regards.

Rogerio Siviero Jr.

makensy13 12th January 2011 13:22

Hello,

Simply generate the key (SSL request) to submit to a trusted authority (Verisign or others). Copy the certificate issued by the trusted authority in the SSL certificate.
There.
Sincerely,

till 12th January 2011 13:22

Please post the exact error message that you got. Depending on the ssl authority that you used to sign the cert, it might be nescessary to add a chain certificate in the additional certs field. You should have received informations about that from the company where you bought the ssl certificate.

rogeriosjr 12th January 2011 14:26

makensy13:
I did it (copied SSL request generated by ISPConfig and generated SSL certificate in http://www.cacert.org/) after that I pasted SSL certificate genereted by CACert into SSL certificate field in ISPConfig.

till:
I copied and pasted "Root Certificate (PEM Format)" and "Intermediate Certificate (PEM Format)" from http://www.cacert.org/index.php?id=3 into SSL bundle field and saved it.
Is it correct?

Into ISPConfig I not see any error, just when a user access the SSL site/url and certificate error (CA Root untrusted etc) is presented by web browser.
I know that it is ocurring because the root/certificate is showed as "localhost.localdomain" but I can't solve/configure it to use root certificate from CACert instead.

Is there any tip to troubleshoot my configuration to be sure I am configuring in the right way?

Regards,

Rogerio Siviero Jr.

rogeriosjr 12th January 2011 19:33

makensy13:
I generated the key (SSL request) correctly and submited to a trusted authority (CACert). After that I pasted it into SSL Certificate filed.

till:
I am not receiveing any error into ISPConfig 3, just when a user access this https site where web browser present a certificate error (root and intermediate) shown as it was issued by "localhost.localdomain" (that I know its incorrect).

I copied and pasted root and intermediate certificates from CACert (Root Certificate_PEM_Format and Intermediate Certificate_PEM_Format from http://www.cacert.org/index.php?id=3) into SSL bundle (ISPConfig) field, but even that the error continue to occur.

--> How can I troubleshoot my configuration to certify that I am doing the correct configuration?

Regards,

Rogerio Siviero Jr.

rogeriosjr 12th January 2011 19:34

makensy13:
I generated the key (SSL request) correctly and submited to a trusted authority (CACert). After that I pasted it into SSL Certificate filed.

till:
I am not receiveing any error into ISPConfig 3, just when a user access this https site where web browser present a certificate error (root and intermediate) shown as it was issued by "localhost.localdomain" (that I know its incorrect).

I copied and pasted root and intermediate certificates from CACert (Root Certificate_PEM_Format and Intermediate Certificate_PEM_Format from http://www.cacert.org/index.php?id=3) into SSL bundle (ISPConfig) field, but even that the error continue to occur.

How can I troubleshoot my configuration to certify that I am doing the correct configuration?

Regards,

Rogerio Siviero Jr.

rogeriosjr 13th January 2011 14:43

makensy13:
I generated the key (SSL request) correctly and submited to a trusted authority (CACert). After that I pasted it into SSL Certificate filed.

rogeriosjr 13th January 2011 14:43

till:
I am not receiveing any error into ISPConfig 3, just when a user access this https site where web browser present a certificate error (root and intermediate) shown as it was issued by "localhost.localdomain" (that I know its incorrect).

I copied and pasted root and intermediate certificates from CACert (Root Certificate_PEM_Format and Intermediate Certificate_PEM_Format from http://www.cacert.org/index.php?id=3) into SSL bundle (ISPConfig) field, but even that the error continue to occur.

How can I troubleshoot my configuration to certify that I am doing the correct configuration?

Regards,

Rogerio Siviero Jr.

rogeriosjr 13th January 2011 14:51

till:
I am not receiveing any error into ISPConfig 3, just when a user access this https site where web browser present a certificate error (root and intermediate) shown as it was issued by "localhost.localdomain" (that I know its incorrect).

I copied and pasted root and intermediate certificates from CACert (Root Certificate_PEM_Format and Intermediate Certificate_PEM_Format from http://www.cacert.org/index.php?id=3) into SSL bundle (ISPConfig) field, but even that the error continue to occur.

How can I troubleshoot my configuration to certify that I am doing the correct configuration?

Regards,

Rogerio Siviero Jr.

falko 13th January 2011 18:01

Any errors in Apache's error logs (the normal one and the SSL error log)?


All times are GMT +2. The time now is 04:55.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.