HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   isp blocks port 25 (http://www.howtoforge.com/forums/showthread.php?t=5085)

snook 22nd June 2006 06:07

isp blocks port 25
 
ISPconfig is very cool and I have most of it working.

So, my isp blocks port 25 and I have got around this in the past by using the smtp redirect service with rollernet.us and port 2525 with another mail server.

I've added to /etc/postfix/master.cf

smtp inet n - n - - smtpd
2525 inet n - n - - smtpd

I can telnet to both 25 and 2525 and get the normal responses and postfix is running.

netstat -tap provides this:

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address Stat e PID/Program name
tcp 0 0 *:imaps *:* LIST EN 1814/xinetd
tcp 0 0 *:pop3s *:* LIST EN 1814/xinetd
tcp 0 0 *:49507 *:* LIST EN 1529/rpc.statd
tcp 0 0 *:mysql *:* LIST EN 1908/mysqld
tcp 0 0 *:pop3 *:* LIST EN 1814/xinetd
tcp 0 0 *:imap *:* LIST EN 1814/xinetd
tcp 0 0 *:sunrpc *:* LIST EN 1511/portmap
tcp 0 0 *:81 *:* LIST EN 2156/ispconfig_http
tcp 0 0 192.168.1.2:domain *:* LIST EN 2418/named
tcp 0 0 hidden.dom:domain *:* LIST EN 2418/named
tcp 0 0 hidden.dom:ipp *:* LIST EN 1765/cupsd
tcp 0 0 hidden.dom:5335 *:* LIST EN 1747/mDNSResponder
tcp 0 0 *:smtp *:* LIST EN 3506/master
tcp 0 0 hidden.dom:rndc *:* LIST EN 2418/named
tcp 0 0 *:2525 *:* LIST EN 3506/master
tcp 0 0 *:http *:* LIST EN 2323/httpd
tcp 0 0 *:ssh *:* LIST EN 1805/sshd
tcp 0 0 localhost:rndc *:* LIST EN 2418/named
tcp 0 0 *:https *:* LIST EN 2323/httpd
tcp 0 148 ::ffff:192.168.1.2:ssh ::ffff:192.168.1.3:2522 ESTA BLISHED 5264/2
tcp 0 0 ::ffff:192.168.1.2:ssh ::ffff:192.168.1.7:54503 ESTA BLISHED 2792/sshd: snook[pr

There is an A record pointing to mail under the domain to the correct global IP.

The MX record points to mail.rollernet.us

However, when I try to point an email client to mail.domain.com or the IP address I get a mail relay access denied when trying to send.. I'm not sure if the issue is with the local ispconfig server or with rollernet. Or maybe both. When I send an email from an external account it disappears. No bounce and no received email.


I've trawled through the forums looking for the answer to this but haven't found it. Probably I've missed something obvious.

lerra 22nd June 2006 09:27

Did you tell postfix to send all mail to rollernet.us? Please check there forum/docs, they should have examples!

Do you get login promt when you try to send mails? Elese you could add your local lan to the relaynetwork. If you dont get login promt you need to specify that authpam should be used for relaying.
Try to send with the webmail application too, check what mail.info/warn says in /var/log

snook 22nd June 2006 09:49

can send
 
OK, have got a little further.

Can now send to external but not receiving anything.

So, if me@example.com (ISPC) sends to me2@xyz.com that works fine. If I reply from me2@xyz.com to that message it disappears. No bounce, no delivery. It's probably the rollernet thing. I'll keep checking.

Also, when I log in the client it does ask for a password which it accepts.

Thanks

falko 22nd June 2006 23:28

Please make sure Maildir is disabled under Management -> Server -> Settings -> Email.

snook 23rd June 2006 04:43

Maildir
 
Hi Falko,

To disable the maildir should that be checked or unchecked? It's currently unchecked.

Thanks

snook 23rd June 2006 12:35

Webmail working
 
Thanks Leera,

Installed the webmail stuff and all the test messages were in there. Can send end to end now this way and need to spend some more time tweaking the pop side. Lack of knowledge really.

I'll post further when I have it figured.

Cheers,

Snook:)

falko 24th June 2006 13:23

Quote:

Originally Posted by snook
To disable the maildir should that be checked or unchecked? It's currently unchecked.

Yes, it must be unchecked.


All times are GMT +2. The time now is 09:03.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.