HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Tips/Tricks/Mods (http://www.howtoforge.com/forums/forumdisplay.php?f=29)
-   -   open ispconfig3 with /panel (http://www.howtoforge.com/forums/showthread.php?t=50695)

tjonger 26th December 2010 22:03

open ispconfig3 with /panel
 
Is it possible to change port :8080 in /panel?
So you can open ispconfig 3 with http://domein.nl/panel

modules 27th December 2010 12:19

i think you can edit /etc/apache2/sites-enabled/000-ispconfig.vhost
Not sure if this will be overwritten on update.

tjonger 27th December 2010 12:49

oke, soo i have change the file but it dont work...somebody who know what i do wrong?

Original:
Code:

Listen 8080
NameVirtualHost *:8080

<VirtualHost _default_:8080>
  ServerAdmin webmaster@localhost
 
  <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
      Options Indexes FollowSymLinks MultiViews +ExecCGI
      AllowOverride AuthConfig Indexes Limit Options FileInfo
      AddHandler fcgid-script .php
      FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
      Order allow,deny
      Allow from all
    </Directory>
  </IfModule>

Change:
Code:

Listen 8080
NameVirtualHost panel.domein.nl

<VirtualHost panel.domein.nl>
  ServerAdmin webmaster@domein.nl
 
  <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
      Options Indexes FollowSymLinks MultiViews +ExecCGI
      AllowOverride AuthConfig Indexes Limit Options FileInfo
      AddHandler fcgid-script .php
      FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
      Order allow,deny
      Allow from all
    </Directory>
  </IfModule>


modules 27th December 2010 12:55

not sure, maybe

Code:

Listen 8080
NameVirtualHost  panel.domein.nl:8080
<VirtualHost  panel.domein.nl:8080>
...


tjonger 27th December 2010 12:56

but i dont want that 8080 port behind the url... Just panel.domein.nl
So how can i fix this?

giftsnake 28th December 2010 20:03

what i did:

inside the panel:
create subdomain with

Host: panel
Domain: domain.nl
Redirect Type: No Flag
Redirect Path: https://hostname.domain.nl:8080
(or http://domain.nl:8080)

vogelor 29th December 2010 11:49

Quote:

Originally Posted by modules (Post 247575)
i think you can edit /etc/apache2/sites-enabled/000-ispconfig.vhost
Not sure if this will be overwritten on update.

this file will be overwritten on update.
if you want to change "this" file. create a new one (for example /etc/apache2/sites-available/ispconfig-my.vhost) and do the changes there.
next change the symlink /etc/apache2/sites-enabled/000-ispconfig and let it point to YOUR file instead of the old one. this will work, because we always update the file itself, but NOT the symlink (if there is one)

Hope, this helps!

tjonger 29th December 2010 11:51

Thanks volgelor, but what do i have to change inside the file?:$


All times are GMT +2. The time now is 04:25.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.