HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Problem Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Fedo (http://www.howtoforge.com/forums/showthread.php?t=50692)

stargazerdood 26th December 2010 18:16

Problem Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Fedo
 
OS: Fedora 14 (i686)
Issue: Postfix deferring mail delivery with the following log entry:
Dec 26 09:50:43 server1 postfix/error[2191]: C023232006B: to=<mike@mydomain.dom>, relay=none, delay=24641, delays=24640/0.32/0/0.01, dsn=4.4.2, status=deferred (delivery temporarily suspended: lost connection with 127.0.0.1[127.0.0.1] while sending DATA command)

Where I think the error is actually occuring:
Dec 26 09:50:43 server1 amavis[2190]: (02190-01) (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=mail;host=127.0.0.1;port=3306' : Can't connect to MySQL server on '127.0.0.1' (13)
Dec 26 09:50:43 server1 amavis[2190]: (02190-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 100) line 241, <GEN13> line 5.
Dec 26 09:50:43 server1 amavis[2190]: (02190-01) (!)Requesting process rundown after fatal error

Steps I have taken to this point:
Checked /etc/amavis/amavis.conf to make sure the sql password and user is correct. I used the same user as the how-to and added my password. The password is correct.

Logged into my sql on host 127.0.0.1 using amavis db (mail_admin) user and password, the connection was successful and a mysql prompt was provided.

I checked /var/log/secure for entries that demonstrated failed logon and there are none.

Any ideas what my problem may be?
Great how-to thanks for posting it.

stargazerdood 27th December 2010 05:36

Problem solved. I noticed an error when amavisd started that /var/dcc/map was unreadable. I double checked my selinux configuration and that was the problem.


All times are GMT +2. The time now is 04:37.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.