HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   My Dovecot is failing when i install ISPConfig 3 (http://www.howtoforge.com/forums/showthread.php?t=50606)

wachira 21st December 2010 04:55

My Dovecot is failing when i install ISPConfig 3
 
All my instalation went well only to the point were I install ISPconfig I get
Dovecot Imap: Error: mail_plugin_dir: Can't access directory: /usr/lib/dovecot/imap/: No such file or directory Fatal: Invalid configuration in /etc/dovecot.conf.
I have tried all the postings northing seems to be working. Can some one help me out on this one.

till 21st December 2010 11:53

1) Which Linux distribution?
2) Is this a 32Bit or 64Bit system?

wachira 21st December 2010 15:35

I am running Centos 5.5 and its a 32 bit system

falko 21st December 2010 16:59

Which tutorial (URL) did you use to set up the server?

What are the outputs of
Code:

ls -la /usr/lib/dovecot/imap/
ls -la /usr/lib64/dovecot/imap/

?

wachira 21st December 2010 17:19

I used http://www.howtoforge.com/perfect-se...64-ispconfig-3. But i would replace the 64 bit part with i386.

The out puts for
[root@wachkama ~]# ls -la /usr/lib64/dovecot/imap/
ls: /usr/lib64/dovecot/imap/: No such file or directory
[root@wachkama ~]# ls -la /usr/lib/dovecot/imap/
ls: /usr/lib/dovecot/imap/: No such file or directory

falko 22nd December 2010 15:31

Did you run this command

Code:

rm -fr /usr/lib/dovecot/
from chapter 10 on http://www.howtoforge.com/perfect-se...ispconfig-3-p4 ?

wachira 22nd December 2010 19:59

Yes I did follow the whole setup very well and at Installing Dovecot I did it to the letter and when I started dovecot it started well. Could it be affected by SquirrelMail webmail. because wen i installed SquirrelMail webmail I didnt get its interface up running. Then when i installed ISPconfig dovecot failed to restart.

falko 23rd December 2010 14:43

The
Code:

rm -fr /usr/lib/dovecot/
is the problem - this command is intended only for 64bit systems because there the Dovecot libraries are in /usr/lib64/dovecot/. On 32bit systems they are in/usr/lib/dovecot/, and you deleted that directory. :(

wachira 23rd December 2010 19:44

Nice it worked perfectly. My ISPconfig is up running. one error only on Install A Chrooted DNS Server (BIND9). When i try to start it it has an error.
Error in named configuration:
/etc/named.conf:29: open: /var/named/chroot/etc/named.conf.local: file not found
[FAILED]
Do u know why?

And in ispconfig it shows that mydns is offline am thinking it is becaues of the above problem.

till 23rd December 2010 19:50

Quote:

Originally Posted by wachira (Post 247414)
Do u know why?

Seems as you did not install bind as described in the tutorial:

http://www.howtoforge.com/perfect-se...ispconfig-3-p5

The tutorial instructs you to create that file.


All times are GMT +2. The time now is 13:22.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.