HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Postfix + Amavis + SpamAssassin + ClamAV (http://www.howtoforge.com/forums/showthread.php?t=5046)

michele 21st June 2006 02:13

Postfix + Amavis + SpamAssassin + ClamAV
 
Hello,

I have read and followed the instructions in the HowTo "Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAssassin, ClamAV)", but I have problems with SpamAssassin and ClamAV.
All incomming email aren't fetched by SpamAssassin and ClamAV.

Al configurations files are the same of the HowTo.
On the syslog, on restarting Amavis, I cann see this lines:

Code:

Jun 21 00:53:02 mtetamaro amavis[3452]: ANTI-VIRUS code      NOT loaded
Jun 21 00:53:02 mtetamaro amavis[3452]: ANTI-SPAM code      NOT loaded
Jun 21 00:53:02 mtetamaro amavis[3452]: ANTI-SPAM-SA code    NOT loaded

How can I resolve this problem? Are people with the same problems?

Thank you for any your effort.

Michele

falko 21st June 2006 19:01

Does your /etc/amavis/amavisd.conf look like the one from the tutorial? Please have a look at the linebreaks, etc. There seems to be a problem when you copy that file with the Internet Explorer.

michele 21st June 2006 19:18

Hello Falko...

I have copied the same amavisd.conf file and correct it.
Today I have reinstalled but always with the same problem:
without AntiVirus and AntiSpam Check...

I don't know how to solve this problem...
All your HowTo has worked good for me... only this... doesn't... :(

Sorry for my english and thank you for your time and your help.

Michele

michele 22nd June 2006 01:02

Hello,

finally I have resolved my problem... after 4 day...
I have a Debian Sarge server and I have installed the last stable amavis-new
from debian repository.

On this debian version (amavisd-new-2.4.1 (20060508)), the amavisd.conf file is ignored. All configuration need to be made in the files in the "/etc/amavis/conf.d/" directory.
In the "/etc/amavis/conf.d/15-content_filter_mode" file, I have removed the # on the two lines @bypass_virus_checks_maps and @bypass_spam_checks_maps.

Now all work.
I need only to check in the 20-debian_defaults if all settings are good and properly configurated for my system.

The next time will be better to read the documentation well before beginning… ;)

I hope this can help if anyone has the same problem.
(perhaps it is the case to point out it in the guide)

Regards,

Michele

j005u 1st July 2006 15:36

using testing here and i have the same problem. i moved the config.d and made a new one inserting the sample config file you gave. no go, virus checks are still disabled.

going to try with the default config.

edit:
adding the lines

@bypass_virus_checks_maps = (
\%bypass_virus_checks, \@bypass_virus_checks_acl, \$bypass_virus_checks_re);

@bypass_spam_checks_maps = (
\%bypass_spam_checks, \@bypass_spam_checks_acl, \$bypass_spam_checks_re);

enables virus checks on debian testing and guessing by the previous poster also on the latest sarge.


All times are GMT +2. The time now is 15:47.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.