HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Tips/Tricks/Mods (http://www.howtoforge.com/forums/forumdisplay.php?f=29)
-   -   SuEXEC + Fast-CGI = upload error 500 (http://www.howtoforge.com/forums/showthread.php?t=50363)

kevin186 4th December 2010 16:49

SuEXEC + Fast-CGI = upload error 500
 
I just finished a new installation of fedora 14 with ispconfig 3 following the perfect server tutorial and I ran into a problem. When I had my websites set to suexec + fast-cgi, I would get error 500 when uploading any files. This happened to my wordpress and slideshowpro director installations. I could not figure it out at first and decided to completely reinstall fedora 14, which still produced the same error and generated the following log:
Code:

[Sat Dec 04 00:39:11 2010] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: HTTP request length 132532 (so far) exceeds MaxRequestLen (131072), referer: http://example.com/wp-admin/themes.php?page=custom-background
The solution was to add the following code to apache directives in the options tab for the website:
Code:

<IfModule mod_fcgid.c>
MaxRequestLen 15728640
</IfModule>

I don't know the cause of this error because my jpeg was not large at all, maybe 500kb. I was able to upload using any other php option for the websites, such as mod-php, cgi, suphp. I found the tip at the following website:http://www.blogtorrent.de/2010/11/30...estlen-131072/

Ovidiu 1st March 2011 01:23

or globally for all sites in this file:

/etc/apache2/mods-available/fcgid.conf


All times are GMT +2. The time now is 09:37.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.