HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   postfix ISPconfig problem (http://www.howtoforge.com/forums/showthread.php?t=503)

matehortua 7th September 2005 01:33

postfix ISPconfig problem
 
hi everyone

i have a suse 9.3 and i follow the Falko manual COMPLETELY and everythink worked OK (in this case mail).
by the way EXELLENT manual. Falko
http://www.falkotimme.com/howtos/per...e9_3/index.php


now, when i finished the ISPconfig installation my mail (Postfix) wasnt working, and i was getting these logs:

Sep 6 18:07:54 acuario postfix/master[24681]: warning: empty macro name: "$#mydestination"
Sep 6 18:07:54 acuario postfix/master[24681]: fatal: dictionary mail_dict: macro processing errorSep 6 18:08:56 acuario postfix[24841]: warning: empty macro name: "$#mydestination"
Sep 6 18:08:56 acuario postfix[24841]: fatal: dictionary mail_dict: macro processing error
Sep 6 18:09:06 acuario postfix/postfix-script: starting the Postfix mail system
Sep 6 18:09:06 acuario postfix/master[24918]: daemon started -- version 2.2.1, configuration /etc/postfix


so, i comment the 3 lines that ISPconfig added to my postfix/main.conf :) and my mail was back :)

relay_domains = $#mydestination
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names

can anyone explain me what should i do, to enable my mail and in the future allow others domain/users mail.
i suppose those lines are very necesary.

tanx
from colombia

till 7th September 2005 09:01

Quote:

Originally Posted by matehortua
hi everyone

i have a suse 9.3 and i follow the Falko manual COMPLETELY and everythink worked OK (in this case mail).
by the way EXELLENT manual. Falko
http://www.falkotimme.com/howtos/per...e9_3/index.php


now, when i finished the ISPconfig installation my mail (Postfix) wasnt working, and i was getting these logs:

Sep 6 18:07:54 acuario postfix/master[24681]: warning: empty macro name: "$#mydestination"
Sep 6 18:07:54 acuario postfix/master[24681]: fatal: dictionary mail_dict: macro processing errorSep 6 18:08:56 acuario postfix[24841]: warning: empty macro name: "$#mydestination"
Sep 6 18:08:56 acuario postfix[24841]: fatal: dictionary mail_dict: macro processing error
Sep 6 18:09:06 acuario postfix/postfix-script: starting the Postfix mail system
Sep 6 18:09:06 acuario postfix/master[24918]: daemon started -- version 2.2.1, configuration /etc/postfix


so, i comment the 3 lines that ISPconfig added to my postfix/main.conf :) and my mail was back :)

relay_domains = $#mydestination
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names

can anyone explain me what should i do, to enable my mail and in the future allow others domain/users mail.
i suppose those lines are very necesary.

tanx
from colombia

Hi,

try to add these three lines:

Code:

mydestination = /etc/postfix/local-host-names
relay_domains = $mydestination
virtual_maps = hash:/etc/postfix/virtusertable

to your main.cf and restart postfix:

Code:

/etc/init.d/postfix restart

matehortua 7th September 2005 22:00

ok i commented out again those 3 lines and I found 1 big error in the line

relay_domains = $#mydestination (the # ISPconfig put it there )
i erase that # and is apparently working becouse the mails are getting in but staying in Queue, soo my users cant read their mail

these are the logs:

Sep 7 14:44:53 acuario postfix/qmgr[28989]: 051D437731: from=<matehortua@gmail.com>, size=1665, nrcpt=1(queue active)
Sep 7 14:44:55 acuario postfix/smtp[29012]: 051D437731: to=<marcos@ims.com.co>, relay=ims.com.co[192.168.1.1], delay=13, status=sent (250 2.6.0 <5c2d4a8b05090712449b7d3af@mail.gmail.com> Queued mail for delivery)
Sep 7 14:44:55 acuario postfix/qmgr[28989]: 051D437731: removed

tanx

falko 9th September 2005 17:44

Quote:

ok i commented out again those 3 lines and I found 1 big error in the line

relay_domains = $#mydestination (the # ISPconfig put it there )
i erase that # and is apparently working becouse the mails are getting in but staying in Queue, soo my users cant read their mail
Yes, you need to remove the # in $#mydestination! Is it working now?

matehortua 12th September 2005 23:11

yes its working tanx
so my conclusion is that ISPconfig add those 3 lines and they are necsesary but the line
relay_domains = $#mydestination

has that # that damages everything. sooo the solution is to erase that # (sharp)
relay_domains = $mydestination


that is a bug that can keep you 1 complete day or even more stopped at work so plezz developrers fix it.

tanx everyone im starting to enjoy my ISPconfig

till 13th September 2005 08:47

Quote:

Originally Posted by matehortua
yes its working tanx
so my conclusion is that ISPconfig add those 3 lines and they are necsesary but the line
relay_domains = $#mydestination

has that # that damages everything. sooo the solution is to erase that # (sharp)
relay_domains = $mydestination


that is a bug that can keep you 1 complete day or even more stopped at work so plezz developrers fix it.

tanx everyone im starting to enjoy my ISPconfig

Hi,

we will try to find out how this can happen. There are some thousand installs from ISPConfig out there and it is the first time that it was reported that quoting the variable is not worked correctly so i'am not shure if we can reproduce this behaviour. But we will try :)

matehortua 14th September 2005 01:08

OK and tanx

my version is ISPconfig-2.0.7
on a suse 9.3
postfix 2.2.1-3

fresh installed with the Falko guide
;)

julianmatz 5th March 2006 16:20

Hello!

Just wanted to say I had the exact same issue. Didn't take me long to fix it but just wanted to report. I installed ISPConfig yesterday... System is Debian Sarge 3.1.

3cwired_com 3rd September 2006 17:03

Ok this was part of my problem also, and I resolved that part as well.


All times are GMT +2. The time now is 10:37.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.