HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Using cgi-bin directory outside ispconfig installation (http://www.howtoforge.com/forums/showthread.php?t=50017)

menahem 14th November 2010 11:08

Using cgi-bin directory outside ispconfig installation
 
Hi all,

As you all know ispconfig uses jalkit in order to chroot web-server as well as mail server erc. That is fine, but: i am experiencing a problem with other application we use cgi-bin directory outside the chrooted system.

In order to pin-point the problem i will give 2 examples (one solved and one did not)

Example 1 mailgraph (This tutorial --> http://howtoforge.net/mail_statistic...ph_pflogsumm):
Mailgraph installation put out cgi-bin files at:/usr/lib/cgi-bin/. If you use the tutorial you will not see any graph because the web-site user is jailed under the web-site directory. In this case i re owned the files at /usr/lib/cgi-bin/ to the web-server user (i.e webX.clentY) and it worked out fine.

Example 2 BackupPC: (this tutorial --> http://howtoforge.net/linux_backuppc) once again cgi-bin files are outside the chrooted web server. I build up the web server user at backuppc installation but it is not working at all.

Another problematic app is nagios who ,once again, put cgi-bin directive out side the chrooted system, and once again (although i owned the cgi-bin directory to web server jailed user) it is not usable.

I will be more the happy if some one has a way howto fix the problem of cgi-bin outside the chrooted web-server user.

B.T.W: in the case of nagios i chaned the apache.conf file that came with the installation so that it will point to the chrooted cgi-bin and made the other needed changes with nagion, never the less it did not worked out nagios did not liked is. I think their should be more system wise solution so that jailed web-site user could read run and activate cgi-bin directories out side jail.

A word about the installation:

O.S: Ubuntu 10.04.1 32 bit web server.Ispconfig3 version 3.0.3

Thank you all,

Menahem

jconstantino 3rd February 2011 20:27

Same problem...
 
Hi, same problem here...
I'm using ISPConfig2 and Nagios3...any help?
Thanks in advance

till 3rd February 2011 22:36

Quote:

Originally Posted by jconstantino (Post 250256)
Hi, same problem here...
I'm using ISPConfig2 and Nagios3...any help?
Thanks in advance

Please post your question in the ispconfig 2 subforum.

ISPConfig 2 and 2 are completely different software packages. So any solution for ispconfig 2 will not work for ispconfig 3 and vice versa.

jconstantino 4th February 2011 15:58

Sorry, I didn't notice this was an ISPConfig3 forum (came from search engine...)
I've checked ISPConfig2 forum, and found no solution...
Thank you for a great great site!

adig 21st January 2013 04:23

Hello,

I know we are in 2013 but I couldn't find anywhere this info:

Is there a solution so I can have ISPConfig and Nagios on the same server?



""Another problematic app is nagios who ,once again, put cgi-bin directive out side the chrooted system,"
"

Thank you in advance.

jconstantino 21st January 2013 14:30

My solution
 
Hi,

I've manage to use Nagios3 with ISPConfig2...I think that this is not a "clean and beautiful" solution, but maybe you can give it a try (replace webXXXX with your virtual server folder):

copy nagios3 cgi to /var/www/webXXX/cgi-bin/nagios3

in nagios3.conf I have:

ScriptAlias /cgi-bin/nagios3 /var/www/webXXX/cgi-bin/nagios3
ScriptAlias /nagios3/cgi-bin /var/www/webXXX/cgi-bin/nagios3

and

<DirectoryMatch (/usr/share/nagios3/htdocs|/var/www/webXXX/cgi-bin/nagios3|/etc/nagios3/stylesheets)>
Options FollowSymLinks +ExecCGI
DirectoryIndex index.php
AddHandler cgi-script .cgi .pl
AllowOverride AuthConfig
Order Allow,Deny
Allow From All

AuthName "blablabla..."
AuthType Basic
AuthUserFile /etc/nagios3/<file users>

require valid-user
</DirectoryMatch>

Hope this can help...

Regards,
Joao Constantino

till 21st January 2013 14:39

Just a note: ISPConfig 2 and 3 are completely different controlpanels, so a setup for ispconfig 2 will not work for ispconfig 3 as the paths and apache setup is different.

jconstantino 21st January 2013 14:46

ISPConfig2 is not ISPConfig3...
 
I'm aware that ispconfig2 and ispconfig3 are diferent (that's why I started to explicity state that my workaround worked for me with ispconfig2...)

I was trying to point a possible path...

Sorry for any inconvenient...

Regards,
Joao Constantino

till 21st January 2013 16:14

Thanks for posting your configuration and it will be helpful for a user with ispconfig for sure.

The paths for ispconfig 3 are:

/var/www/clients/client[CLIENTID]/web[WEBID]/cgi-bin/

adig 21st January 2013 23:47

Oh my God, it's working... :)

Thank you so much!


All times are GMT +2. The time now is 00:17.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.