HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Forwarding mail if unser unknown possible? (http://www.howtoforge.com/forums/showthread.php?t=50006)

truster 13th November 2010 13:10

Forwarding mail if unser unknown possible?
 
Hello, I have setup a server with this great howto: http://www.howtoforge.com/perfect-se...nx-ispconfig-3

Everything works fine, but i have the following situation:

i use the e-mail domain from my isp (@aon.at) with getmail. All outgoing mail goes to the smtp server from the isp. if i send a e-mail to an address, that is not in my virtual mailbox table, for example: xyz@aon.at, i get the following message:
Quote:

5.1.1 <xyz@aon.at>: Recipient address rejected: User unknown in virtual mailbox table.
send to all other domains works.

is it possible to forward those mail to an external relay host?
In Exchange 2003 i had to delegate the domain as non-authoritative and added a transport for aon.at. All unresolved adresses would be forwarded to the specified host.

Is this possible with ISPConfig3?

Any Help would be greatly appreciated.

Thanks.

falko 14th November 2010 19:42

Yes, you can do this with the Email Routing feature (it uses Postfix transports).

truster 14th November 2010 20:11

Hi Falko, thanks for your reply!

If i add a e-mail routing for aon.at, all mails fetched with getmail will also be forwarded, so i get a loop (aon pop account > getmail > local smtp > aon smarthost smtp > aon popaccount. the aon smtp server detects the loop and dropped the mail
And Thunderbird keeps display the message, if i try to send to an aon.at address.

truster 14th November 2010 23:46

ok, this one is not the solution, but a workaround:

i disabled the aon.at domain (and mailboxes) and createt the aon.local domain.
i assigned the alias myemail@aon.at with myemail@aon.local box and also configured getmail this way.

It's not the ultimate solution, but it works.

btw: how can i make this thread as solved?


All times are GMT +2. The time now is 04:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.