HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Error code: ssl_error_rx_record_too_long (http://www.howtoforge.com/forums/showthread.php?t=49967)

SamTzu 11th November 2010 11:27

Error code: ssl_error_rx_record_too_long
 
After creating the SSL certs in ISPConfig3...

For some reason I had to enter the <IfModule mod_ssl.c> part manually to the apache vconf file to get SSL to work. /etc/apache2/sites-available/order.i-order.info.vhosts

Anyway now the SSL works for that site.


Quote:

<IfModule mod_ssl.c>
################################################## #########
# SSL Vhost
################################################## #########

<VirtualHost 79.134.125.159:443>
DocumentRoot /var/www/clients/client1/web2/web

ServerName order.i-order.info
ServerAlias *.order.i-order.info
ServerAdmin webmaster@order.i-order.info

ErrorLog /var/log/ispconfig/httpd/order.i-order.info/error.log

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

SSLEngine on
SSLCertificateFile /var/www/clients/client1/web2/ssl/order.i-order.info.crt
SSLCertificateKeyFile /var/www/clients/client1/web2/ssl/order.i-order.info.key

<Directory /var/www/order.i-order.info/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>
<Directory /var/www/clients/client1/web2/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>

# cgi enabled
<Directory /var/www/clients/client1/web2/cgi-bin>
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ /var/www/clients/client1/web2/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
# Clear PHP settings of this website
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
# suphp enabled
<Directory /var/www/clients/client1/web2/web>
<IfModule mod_suphp.c>
suPHP_Engine on
# suPHP_UserGroup web1 client1
AddHandler x-httpd-suphp .php .php3 .php4 .php5
suPHP_AddHandler x-httpd-suphp
</IfModule>
</Directory>

# add support for apache mpm_itk
<IfModule mpm_itk_module>
AssignUserId web1 client1
</IfModule>

<IfModule mod_dav_fs.c>
# DO NOT REMOVE THE COMMENTS!
# IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
# WEBDAV BEGIN
# WEBDAV END
</IfModule>


</VirtualHost>
</IfModule>

SamTzu 12th November 2010 09:15

I could probably just add that to the Options|Apache leaf on Site page if that happens again. Right?

<IfModule mod_ssl.c>
...
<IfModule>
...
</IfModule>

falko 12th November 2010 13:56

Do you mean the Apache Directives field? No, that will not work because these directives will be written somewhere else in your vhost config, so you have one section for SSL and then another section with your custom directives in your vhost config.


All times are GMT +2. The time now is 17:35.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.