HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   ssl problems (http://www.howtoforge.com/forums/showthread.php?t=49668)

stevegjacobs 26th October 2010 18:12

ssl problems
 
Hi
I added extra ip address and an ssl certificate for one domain in ispconfig 3. However I discovered that I had generated a csr for domainname.com instead of www.domainname.com. So I generated a new corrected csr and got back to the ssl provider and had the correct version re-issued. However , after saving the new ssl cert into the control panel, Apache2 refused to restart and killed all my sites. The only way I was able to get this back up again was to manually edit the file for this site in /etc/apache2/sites-enabled/ so that ssl engine was turned off. This is a new site under development but it is ready for testing, so I need to get the cert installed properly. Any idea why this happened?
ISPconfig 3.0.2.1 on Debian 5.0

Thanks

Steve Jacobs

ivomendonca 26th October 2010 20:27

yes, you have to delete manualy the ssl files from vhost.
And then try again.

Thats error was allready fixed, install the latest version and try.

stevegjacobs 29th October 2010 13:11

I upgraded the server yesterday and most everything seemed fine. then I installed the new ssl cert and that worked as well, but I found another problem. A number of sites that share an ip address are all pointing to the same site. I also am getting these errors when restarting apache.
Code:

webserver1:~# /etc/init.d/apache2 restart
Restarting web server: apache2[Fri Oct 29 11:59:56 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:56 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:56 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:56 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:56 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:56 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:56 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:56 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:56 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
 ... waiting .[Fri Oct 29 11:59:58 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:58 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:58 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:58 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:58 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:58 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:58 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:58 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Oct 29 11:59:58 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
.

This is urgent as several sites seem to be down right now.

Thanks

stevegjacobs 29th October 2010 14:38

Several sites down - please help
 
How do I fix this NameVirtualHost problem? I think this first occurred following add an ssl cert, but it also could have something to do with updating, which I did the day before.
Many instances of the following when restarting apache:
Code:

[Fri Oct 29 13:29:55 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
Thanks
Steve

Debian5
Very latest ISPConfig

falko 30th October 2010 14:36

What's the output of
Code:

cd /etc/apache2
grep -Ri namevirtualhost *

I think there should be the line
Code:

NameVirtualHost 78.153.221.50:80
in /etc/apache2/ports.conf.

jtheed 30th October 2010 17:16

Quote:

Originally Posted by stevegjacobs (Post 243217)
How do I fix this NameVirtualHost problem? I think this first occurred following add an ssl cert, but it also could have something to do with updating, which I did the day before.
Many instances of the following when restarting apache:
Code:

[Fri Oct 29 13:29:55 2010] [warn] VirtualHost 78.153.221.50:80 overlaps with VirtualHost 78.153.221.50:80, the first has precedence, perhaps you need a NameVirtualHost directive
Thanks
Steve

Debian5
Very latest ISPConfig

Till had me do this and it solved this problem for me.

In ISPConfig go to system > server IP, click on a ip, disable the namevirtualhost checkbox and click on save. The click on the same ip, enable the checkbox again and click on save.


All times are GMT +2. The time now is 06:52.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.