HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   vhosts issue after upgrading from 3.0.2 to 3.0.3 - no server (http://www.howtoforge.com/forums/showthread.php?t=49286)

md@waw.co.uk 6th October 2010 22:48

vhosts issue after upgrading from 3.0.2 to 3.0.3 - no server
 
I have just upgraded to 3.0.3 (on a testing server)

Apache is not working

When I try to restart Apache2 I get this error message

*********** START MESSAGE ************

Restarting web server: apache2Syntax error on line 6 of /etc/apache2/sites-enabled/000-ispconfig.vhost:
Listen requires 1 or 2 arguments.

*********** END MESSAGE **************

This is the vhosts file


################################################## ####
# This virtual host contains the configuration
# for the ISPConfig controlpanel
################################################## ####

Listen apt-get install sudo

NameVirtualHost *:apt-get install sudo

<VirtualHost _default_:apt-get install sudo>
ServerAdmin webmaster@localhost

<IfModule mod_fcgid.c>
DocumentRoot /var/www/ispconfig/
SuexecUserGroup ispconfig ispconfig
<Directory /var/www/ispconfig/>
Options Indexes FollowSymLinks MultiViews +ExecCGI
AllowOverride AuthConfig Indexes Limit Options FileInfo
AddHandler fcgid-script .php
FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
Order allow,deny
Allow from all
</Directory>
</IfModule>

<IfModule mod_php5.c>
DocumentRoot /usr/local/ispconfig/interface/web/
AddType application/x-httpd-php .php
<Directory /usr/local/ispconfig/interface/web>
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
php_value magic_quotes_gpc 0
</Directory>
</IfModule>

# ErrorLog /var/log/apache2/error.log
# CustomLog /var/log/apache2/access.log combined
ServerSignature Off

<IfModule mod_security2.c>
SecRuleEngine Off
</IfModule>

# SSL Configuration
#SSLEngine On
#SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
#SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key

</VirtualHost>

<Directory /var/www/php-cgi-scripts>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<Directory /var/www/php-fcgi-scripts>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&& END VHOST FILE

Can anyone kindly tell me what's wrong

thanks

till 6th October 2010 23:29

Looks as if you typed in:

apt-get install sudo

as the updaterasked you for the ispconfig port. Replace every occurrence of "apt-get install sudo" with 8080 and restart apache.

Torch_za 6th October 2010 23:44

err .. not sure just how you did it but ..
 
it looks like to did a search and replace of :8080 with :apt-get install sudo

go back edit the file replacing the ":apt-get install sudo" with ":8080"
save and restart apache

md@waw.co.uk 7th October 2010 13:02

done that - now I get this
 
Thanks for your suggestion(s)

During the install I was not asked for the ISPconfig port... and I certainly didn't edit the file with a search & replace.

I've edited the file and now I get this message when I try to restart Apache (and Apache isn't starting)


server1:~# /etc/init.d/apache2 restart
Restarting web server: apache2[Thu Oct 07 11:51:50 2010] [warn] NameVirtualHost *:8080 has no VirtualHosts
[Thu Oct 07 11:51:50 2010] [warn] NameVirtualHost *:8080 has no VirtualHosts
(98)Address already in use: make_sock: could not bind to address [::]:8080
.
server1:~#


Any suggestions gratefully received

falko 7th October 2010 15:04

Please reboot the server.

md@waw.co.uk 7th October 2010 15:29

After a re-boot
 
Thank you for the fast reply - I have rebooted the server

still no Apache

this is the message I get when I try to restart


server1:~# /etc/init.d/apache2 restart
Restarting web server: apache2[Thu Oct 07 14:27:33 2010] [warn] NameVirtualHost *:8080 has no VirtualHosts
[Thu Oct 07 14:27:33 2010] [warn] NameVirtualHost *:8080 has no VirtualHosts
(98)Address already in use: make_sock: could not bind to address [::]:8080
.
server1:~#

till 7th October 2010 21:05

you seem to run another software on port 8080. You can check with the command:

netstat -tap

which other software is running on that port. Then either reconfigure this software to run on another port or reconfigure ispconfig to run on another port.

md@waw.co.uk 7th October 2010 21:29

All sorted - Thank you
 
Hello

I found a copy of the vhosts file .save.1 - I changed the port in that file & now it appears to all be working. Thank you for your kind assistance.

till 7th October 2010 21:36

Please delete this .save-1 file. It is not from ispconfig and was most likely created as you edited the file and there shall be no duplicate vhosts defined in the apache configuration.


All times are GMT +2. The time now is 00:32.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.