HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   Odd: same client, different domains sharing accounts? (http://www.howtoforge.com/forums/showthread.php?t=49172)

h0t1ce 30th September 2010 17:26

Odd: same client, different domains sharing accounts?
 
Hi,

I have a client that has 2 domains. example: comp1.com and comp2.com

only one account employee@comp1.com was created. But for some reason sending an email to employee@comp2.com (doesn't exist) will send the email to employee@comp1.com.

Is there a setting to prevent this from happening?

thanks for your time


Martin

till 1st October 2010 10:55

Is the second domain a separate website or is it a co-domain?

h0t1ce 1st October 2010 14:40

Both domains are individual entries in the "sites" folder.

Looking at the 'co-domain' tab for each doesn't show an entry of the other domain either.

till 1st October 2010 14:48

Ok, then the domain names are not connected. Have you disblaed username prefixes? If employee is a linux username, then it will catch emails from all domains where the email address starts with employee@.... To prevent that, edit the file /home/admispconfig/ispconfig/lib/config.inc.php and cahnge the line:

$go_info["server"]["postfix_config"] = 1;

to:

$go_info["server"]["postfix_config"] = 2;

then edit the mailbox settings of a user in ispconfig, e.g. change quota and click on save so that the configuration file gets rewritten.

h0t1ce 5th October 2010 22:57

1 Attachment(s)
Thanks for the fast reply. Didn't notice your second reply since I didnt get an email alert.

I tried changing the setting then changing the quota of one user in the web frontend to have it regenerate the file.

Now users are getting this email sent to them in large quantities.

See attachment for an example email being received.


thank you

falko 6th October 2010 14:52

Is localhost.localdomain listed in /etc/hosts?

h0t1ce 6th October 2010 15:07

localhost.localdomain is actually mentioned twice in /etc/hosts. But it's because there's two lines for 127.0.0.1. Which I find a little odd, hopefully that doesn't cause conflict.


127.0.0.1 www.company123.com www localhost.localdomain localhost
10.20.40.122 www.company123.com www
127.0.0.1 localhost.localdomain localhost


I did notice that localhost.localdomain wasn't in /etc/local-host-names
Could that be the problem?

I'm a little worried to bombard my mailboxes with hundreds of the error email again. Is there a way to avoid that message temporarily from being delivered?

thank you so much for your time.

falko 7th October 2010 14:22

Quote:

Originally Posted by h0t1ce (Post 241096)
localhost.localdomain is actually mentioned twice in /etc/hosts. But it's because there's two lines for 127.0.0.1. Which I find a little odd, hopefully that doesn't cause conflict.


127.0.0.1 www.company123.com www localhost.localdomain localhost
10.20.40.122 www.company123.com www
127.0.0.1 localhost.localdomain localhost

Should be no problem, but nevertheless I'd remove the last line.

Quote:

Originally Posted by h0t1ce (Post 241096)
I did notice that localhost.localdomain wasn't in /etc/local-host-names
Could that be the problem?

Do you mean /etc/postfix/local-host-names? If so, add localhost.localdomain to it (at the end where you are allowed to make modifications) and restart Postfix.


All times are GMT +2. The time now is 00:18.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.