HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   pop3 and bind offline (http://www.howtoforge.com/forums/showthread.php?t=49161)

gamera 30th September 2010 14:35

pop3 and bind offline
 
Hey there guys,

Having some issues with my centos (perfect server) ispconfig 2 server.

Recently bind has not been updating but I haven't had time to investigate too much other than searching around on the forums.

This morning after the server was restarted both pop3 and bind are offline. Restarting didnt fix it.

Directory in server config>settings
named.conf: /var/named/chroot/etc/named.conf

Contents of which:

options {
pid-file "/var/named/chroot/var/run/named/named.pid";
directory "/var/named/chroot/var/named";
auth-nxdomain no;
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
// query-source address * port 53;
};

//
// a caching only nameserver config
//
zone "." {
type hint;
file "named.root";
};

zone "0.0.127.in-addr.arpa" {
type master;
file "named.local";
};

zone "226.122.203.in-addr.arpa" {
type master;
file "pri.226.122.203.in-addr.arpa";
};


zone "maverickrenegades.com" {
type master;
file "pri.maverickrenegades.com";
};
zone "mythicalsystems.com" {
type master;
file "pri.mythicalsystems.com";
};
zone "inspite.com.au" {
type master;
file "pri.inspite.com.au";
};
zone "spookyink.net" {
type master;
file "pri.spookyink.net";
};



//// MAKE MANUAL ENTRIES BELOW THIS LINE! ////



Not sure which logs to include. Please let me know what i can supply for assistance...

I am contemplating re-install and upgrade to ispconfig3 but i just dont have the time atm.

till 1st October 2010 10:56

Please restart bind and then look into the syslog or messages log if there are any bind related errors in these files.

gamera 7th October 2010 13:50

[root@server1 ~]# /etc/init.d/named restart
Stopping named: [ OK ]
Starting named: [FAILED]

Checked Messages in /etc/log/
Did not have anything in there..last log entry 3 days ago. FAIL

Can you please tell me where I can find the log for bind as I cant find one in the same directory?

gamera 8th October 2010 00:25

Oct 8 08:50:29 server1 named[5092]: starting BIND 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2 -u named -t /var/named/chroot
Oct 8 08:50:29 server1 named[5092]: adjusted limit on open files from 1024 to 1048576
Oct 8 08:50:29 server1 named[5092]: found 1 CPU, using 1 worker thread
Oct 8 08:50:29 server1 named[5092]: using up to 4096 sockets
Oct 8 08:50:29 server1 named[5092]: loading configuration from '/etc/named.conf'
Oct 8 08:50:29 server1 named[5092]: using default UDP/IPv4 port range: [1024, 65535]
Oct 8 08:50:29 server1 named[5092]: using default UDP/IPv6 port range: [1024, 65535]
Oct 8 08:50:29 server1 named[5092]: listening on IPv4 interface lo, 127.0.0.1#53
Oct 8 08:50:29 server1 named[5092]: listening on IPv4 interface eth0, 10.10.1.6#53
Oct 8 08:50:29 server1 named[5092]: command channel listening on 127.0.0.1#953
Oct 8 08:50:29 server1 named[5092]: command channel listening on ::1#953
Oct 8 08:50:29 server1 named[5092]: the working directory is not writable
Oct 8 08:50:29 server1 named[5092]: couldn't open pid file '/var/named/chroot/var/run/named/named.pid': File exists
Oct 8 08:50:29 server1 named[5092]: exiting (due to early fatal error)

gamera 8th October 2010 10:46

Well I think I fixed it... Reapplied this from perfect server config.

chmod 755 /var/named/
chmod 775 /var/named/chroot/
chmod 775 /var/named/chroot/var/
chmod 775 /var/named/chroot/var/named/
chmod 775 /var/named/chroot/var/run/
chmod 777 /var/named/chroot/var/run/named/
cd /var/named/chroot/var/named/
ln -s ../../ chroot
touch /var/named/chroot/etc/named.conf
chkconfig --levels 235 named on
/etc/init.d/named start

And yes its back up! Now to test to see if DNS will update.

I have no idea what happened to cause the error.


All times are GMT +2. The time now is 20:31.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.