HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Pure-ftpd: Connection refused when connecting from outside of LAN (http://www.howtoforge.com/forums/showthread.php?t=49157)

zabersoft 30th September 2010 12:44

Pure-ftpd: Connection refused when connecting from outside of LAN
 
Hi,

I know this isn't strictly an ISPConfig 3 question - but my problem is on a box which is set up according to the The Perfect Server guide for Debian (http://www.howtoforge.com/perfect-se...-ispconfig3-p4) - so I thought I might give it a go posting my question here.

Basically the problem rests in being unable to connect to FTP from outside of my LAN. Yes, I know the first thing I should check is if my ports are open - and they most certainly are! Let me break it down:

1) I can connect fine locally if I use the servers IP directly from other machines on the LAN (also telnet localhost 21 on the server works fine)

2) I can connect to the server fine externally on other ports, such as 80 and 22 (HTTP and SSH)

3) Ports 20 and 21 are open through to my server

But when I try to connect, I get a "Connection Refused" message.

4) I then check to see if pure-ftpd is running - it is. Also, netstat -lnptu gives me:

Code:

tcp        0      0 0.0.0.0:48064          0.0.0.0:*              LISTEN      2051/rpc.statd
tcp        0      0 192.168.0.110:9000      0.0.0.0:*              LISTEN      4123/twonkymediaser
tcp        0      0 127.0.0.1:9000          0.0.0.0:*              LISTEN      4123/twonkymediaser
tcp        0      0 127.0.0.1:5000          0.0.0.0:*              LISTEN      4080/rtorrent
tcp        0      0 127.0.0.1:10024        0.0.0.0:*              LISTEN      2295/amavisd (maste
tcp        0      0 127.0.0.1:10025        0.0.0.0:*              LISTEN      3740/master
tcp        0      0 0.0.0.0:3306            0.0.0.0:*              LISTEN      2450/mysqld
tcp        0      0 127.0.0.1:623          0.0.0.0:*              LISTEN      3839/famd
tcp        0      0 127.0.0.1:783          0.0.0.0:*              LISTEN      2514/spamd.pid
tcp        0      0 0.0.0.0:111            0.0.0.0:*              LISTEN      2040/portmap
tcp        0      0 0.0.0.0:10000          0.0.0.0:*              LISTEN      3958/perl
tcp        0      0 0.0.0.0:21              0.0.0.0:*              LISTEN      6456/pure-ftpd (SER
tcp        0      0 192.168.0.110:53        0.0.0.0:*              LISTEN      3666/mydns
tcp        0      0 127.0.0.1:53            0.0.0.0:*              LISTEN      3666/mydns
tcp        0      0 0.0.0.0:22              0.0.0.0:*              LISTEN      2267/sshd
tcp        0      0 0.0.0.0:25              0.0.0.0:*              LISTEN      3740/master
tcp        0      0 0.0.0.0:55998          0.0.0.0:*              LISTEN      4080/rtorrent
tcp6      0      0 :::993                  :::*                    LISTEN      3643/couriertcpd
tcp6      0      0 :::995                  :::*                    LISTEN      3661/couriertcpd
tcp6      0      0 :::139                  :::*                    LISTEN      3801/smbd
tcp6      0      0 :::110                  :::*                    LISTEN      3649/couriertcpd
tcp6      0      0 :::143                  :::*                    LISTEN      3631/couriertcpd
tcp6      0      0 :::8080                :::*                    LISTEN      3898/apache2
tcp6      0      0 :::80                  :::*                    LISTEN      3898/apache2
tcp6      0      0 :::8081                :::*                    LISTEN      3898/apache2
tcp6      0      0 :::21                  :::*                    LISTEN      6456/pure-ftpd (SER
tcp6      0      0 ::1:53                  :::*                    LISTEN      3666/mydns
tcp6      0      0 :::22                  :::*                    LISTEN      2267/sshd
tcp6      0      0 :::443                  :::*                    LISTEN      3898/apache2
tcp6      0      0 :::445                  :::*                    LISTEN      3801/smbd


AFAIK then after setting everything up with the Perfect Server guide then my system isn't using inetd for ftp - so the hosts.allow file shouldn't factor into this - I did add ftpd : ALL : ALLOW to it however to no avail.

And no, I am not trying to access the server from within my lan using the external IP (which could result in a NAT loopback problem if my router doesn't support it... Which I actually don't think it does) - I have been using this service to test with:

http://www.wormly.com/test_ftp_server

So, it looks to me that my Debian box is actively refusing connections on port 21 if it is coming from outside the LAN. What can I do to resolve this?

Thanks! :)

falko 1st October 2010 16:04

Have you tried both active and passive transfers in your FTP client?


All times are GMT +2. The time now is 13:42.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.