HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   apache cannot start after creating a new site (http://www.howtoforge.com/forums/showthread.php?t=48877)

orasis 18th September 2010 23:01

apache cannot start after creating a new site
 
I made a new site yesterday with all default settings, didn't touch anything except I created a db for it to mess with some old db I had etc.

today I run ubuntu again and apache won't start
I run:
/etc/init.d/apache2 start

and get:

Code:

* Starting web server apache2                                                                                                                                                                                    Warning: DocumentRoot [/var/www/example.bounceme.net/web] does not exist
Syntax error on line 54 of /etc/apache2/sites-enabled/example.bounceme.net.vhost:
can't get fastcgi file info: /var/www/php-fcgi-scripts/web2/.php-fcgi-starter(/var/www/php-fcgi-scripts/web2/.php-fcgi-starter), errno: 2
                                                                                                                                                                                                          [fail]



contents of example.bounceme.net.vhost are:

Code:

<Directory /var/www/example.bounceme.net>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost *:80>
      DocumentRoot /var/www/example.bounceme.net/web
 
    ServerName example.bounceme.net
    ServerAdmin webmaster@example.bounceme.net

    ErrorLog /var/log/ispconfig/httpd/example.bounceme.net/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html
   
    <Directory /var/www/example.bounceme.net/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    <Directory /var/www/clients/client3/web2/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>

    # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
    </FilesMatch>
    # php as fast-cgi enabled
    <IfModule mod_fcgid.c>
      # SocketPath /tmp/fcgid_sock/
      IdleTimeout 3600
      ProcessLifeTime 7200
      # MaxProcessCount 1000
      DefaultMinClassProcessCount 3
      DefaultMaxClassProcessCount 100
      IPCConnectTimeout 8
      IPCCommTimeout 360
      BusyTimeout 300
    </IfModule>
    <Directory /var/www/example.bounceme.net/web>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    <Directory /var/www/clients/client3/web2/web>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
      AssignUserId web2 client3
    </IfModule>


</VirtualHost>


any help please ? I am noob and only solution for me without a help will be to reinstall server ... much mess !
any help appreciated

orasis 19th September 2010 01:20

very nice

guess what. I reinstalled the server all from scratch.
created a new site, made a db and an ftp user for it.

all connected fine except ftp user.

so I restarted computer.
same result as above but with web1 this time.

it was working perfect. go NO IDEA what went wrong with it....

edit: I am following this step by step and doing it all perfect:
http://www.howtoforge.com/perfect-se...10-ispconfig-3


the exact msg I get on terminal after apache restart is this:

* Restarting web server apache2
Warning: DocumentRoot [/var/www/example.bounceme.net/web] does not exist
apache2: bad user name web1

orasis 19th September 2010 02:23

well I am reinstalling again (HAPPY HOURS !!)

some comments I would like you to clear for me if possible,
I always get stuck at this point on this page:
The Perfect Server - Ubuntu 9.10 [ISPConfig 3] - Page 4
Next we install maildrop as follows:

update-alternatives --remove-all maildir.5
update-alternatives --remove-all maildirquota.7

I get the this on terminal:
update-alternatives: error: no alternatives for maildir.5.

so searching for this I found this topic:
http://www.howtoforge.com/forums/showthread.php?t=43518

.. and this rsd-17 guy suggests to do place them like this that doesn't give back an error so this is what I do:

update-alternatives --remove-all maildir.5.gz
update-alternatives --remove-all maildirquota.7.gz

hope this is not what causes the mess !

till 19th September 2010 11:14

As you reinstalled the server, we are not able to help you with fixing the problem.

orasis 19th September 2010 16:56

sure............................

till 19th September 2010 17:40

How shall we able to help you when you remove the files that caused the problem. You are really funny. ;)

If your car is not working and you go to a garage and ask them what the problem is. They tell you to show them the car and then you say, oh, you want to see my car. I dont have it anymore....

orasis 19th September 2010 17:50

of course this is absolutely logical, of course I know that, but thanks for explaining.

All I mean is, I got no idea how it happened. Now it works because I didn't touch the php.ini files yet.

When it comes to this moment I think the problem will come back !

till 19th September 2010 17:53

You have not mentioned in your prior posts that the problems started after you changed a php.ini file. If you say what you changed in the php.ini, we might be able to tell you why it caused that problemand how to solve it.

orasis 19th September 2010 18:01

I agree, but now, cause when it happened I didn't know such changes can screw it,
All I had changed was these:

/etc/php5/cgi/
/etc/php5/apache2/
/etc/php5/cli/

changes:
display_errors = Off
disable_functions = show_source, system, shell_exec, passthru, exec, phpinfo, popen, proc_open
allow_url_fopen = Off
memory_limit = 64M
upload_max_filesize = 50M
post_max_size = 64M
max_execution_time = 300
session.gc_maxlifetime = 10000


make ftpd show hidden files:
echo "yes" > /etc/pure-ftpd/conf/DisplayDotFiles


you think those could affect ?

till 19th September 2010 20:38

The problem was that you disabled system, shell_exec, passthru, exec, popen, proc_open for cli-php. ISPConfig is a php script and if you disable exec for commandline scripts, then you disable the ability that ispconfig can configure your server. Disabling exec for php-cli is not nescessary as it is already a commandline script itself.


All times are GMT +2. The time now is 02:07.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.