HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Programming/Scripts (http://www.howtoforge.com/forums/forumdisplay.php?f=7)
-   -   Help config Awstats (http://www.howtoforge.com/forums/showthread.php?t=486)

domino 5th September 2005 16:00

Help config Awstats
 
I have installed FC3 Awstats RPM. I think I have it configured correctly and from webmin, all the settings seam to be correct. I ran an update without errors and not getting errors when I set to update in cron. The only problem is, when I try to browse the main server domain awstats directory, I get an internal server error.

I tailed the error log but perl just doesn't give enough info on the error in order for me to t-shoot. Here is the error.

Quote:

[Mon Sep 05 08:05:24 2005] [error] [client 210.5.xxx.xxx] Premature end of script headers: awstats.pl,
Anyone successful in getting awstats to work, help me pleas?

till 5th September 2005 16:17

Quote:

Originally Posted by domino
I have installed FC3 Awstats RPM. I think I have it configured correctly and from webmin, all the settings seam to be correct. I ran an update without errors and not getting errors when I set to update in cron. The only problem is, when I try to browse the main server domain awstats directory, I get an internal server error.

I tailed the error log but perl just doesn't give enough info on the error in order for me to t-shoot. Here is the error.



Anyone successful in getting awstats to work, help me pleas?

My answer is not AW-Stats specific, but maybe it helps anyway.

Does the perl script belong to the correct user and group and has the rights 755. Is the path to the perl interpreter correct in the head of the script?

domino 5th September 2005 16:42

Yes, I chmodded 755 and 777 awstats.pl and chown site1owner.site1group, based on the user wheel. Should have set it to apache.apache? The shabang location for perl is in the right place. Do you think it would help to set the permission to ALL files and folders under the cgi-bin dir?

till 5th September 2005 20:56

Quote:

Originally Posted by domino
Yes, I chmodded 755 and 777 awstats.pl and chown site1owner.site1group, based on the user wheel. Should have set it to apache.apache? The shabang location for perl is in the right place. Do you think it would help to set the permission to ALL files and folders under the cgi-bin dir?

Yes, i think it must be apache:apache.

If this wont help, i would try to set the permissions to the other files too. But make a backup of the files with existing permissions before :D

domino 6th September 2005 06:47

Ok. setting tarred the entire awstats directory :D. I just changed user and group to apache and gave everything inside the cgi-bin 755. Seams to work fine now. Thanks for the directions.


All times are GMT +2. The time now is 00:02.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.