HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   New Setup Email Configuration problems (http://www.howtoforge.com/forums/showthread.php?t=4837)

jerutley 12th June 2006 08:00

New Setup Email Configuration problems
 
Well, I finally got my ISPConfig setup going today, and it pretty much seems to be working fine, except for one problem. I've tried to load up a test domain, nw7ju.org, into my configuration. I create a new client named nw7ju, and do all the configuration for that, and everything is fine. I then go to create the new site for www.nw7ju.org, and everything there works fine as well. But, here's the sticky part - in /etc/postfix/local-host-names, the name "www.nw7ju.org" is written in, not "nw7ju.org" as I would expect, which causes emails sent to my new email user nw7ju@nw7ju.org to be returned for a relay violation. So, I go back to my site config, and remove the "www" hostname. When I save the changes, ispconfig removes the "www" from the entry in local-host-names, and all would be fine...except that if I return to the site configuration in ISPConfig again, the www hostname returns, and any changes will re-write "www.nw7ju.org" into local-host-names.

I'm sure I'm probably missing something obvious, but I don't know what, so any help anyone can give me would be greatly appreciated. If you need more information, please let me know!

Jeremy

till 12th June 2006 09:50

Please add a co-domain nw7ju.org (with empty host field) to the website www.nw7ju.org

jerutley 12th June 2006 22:06

Thanks Till! I actually figured that one out late last night, and got everything working!


All times are GMT +2. The time now is 22:33.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.