HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Domains not mapping to site folders (http://www.howtoforge.com/forums/showthread.php?t=47913)

WDL 12th August 2010 10:56

Domains not mapping to site folders
 
Hi all,

I've had a trawl through the forum for this problem, and have applied the fixes I found with no luck.

We have a server running Ubuntu Server 10.04 and ISPConfig 3. It sits behind a router with two internal addresses (on eth0 and eth0:0). Those two internal addresses are DMZ'd and address mapped to 2 public IP's on the router.

ISPConfig is up and running, we have added the client and the site. The server is running BIND9 happily, and the domain routes to our server fine.

The problem is that when you navigate to the domain in question, you get the server's root index.html.

The domain is included as a virtualhost in apache2.conf and everything looks good. A quick summary of the config is:

- server has 2 public IPs mapped to 2 private IPs
- DNS has A records for domain and www.domain on public IP
- site is configured with private IP (have also tried using public)
- site has autosubdomain (www.)
- can ftp to the site folder fine

One other thing that is odd is that if you navigate from the server root to the site folder i.e. http://www.domain.com/sites/domain.com/ you get a 403 permission denied error page.

So, any ideas? I'm happy to dump up relevant config and outputs if asked for.

Cheers in advance!
(fingers crossed)

till 12th August 2010 15:30

Ensure that you have selected the same IP address in the website settings then you have used for the DNS A-Record of the domain and www subdomain. Also check that you have activated auto subdomain www and that there are no jobs listed anymore in the jobqueue in the ispconfig monitor.

mike_p 12th August 2010 19:17

Quote:

Originally Posted by WDL (Post 236265)
... The domain is included as a virtualhost in apache2.conf ...

Maybe the Apache setup on Ubuntu is different to Centos, but AFAIK the virtual host for your site should not be in apache2.conf.

1/ Do you mean apache2.conf or httpd.conf?

2/ The virtual host settings should be in a file (one per domain) in "sites-available" with a pointer from "sites-enabled".

Toucan 13th August 2010 03:36

Quote:

Originally Posted by mike_p (Post 236331)
Maybe the Apache setup on Ubuntu is different to Centos, but AFAIK the virtual host for your site should not be in apache2.conf.

1/ Do you mean apache2.conf or httpd.conf?

2/ The virtual host settings should be in a file (one per domain) in "sites-available" with a pointer from "sites-enabled".

This is how it is in debian, ubuntu's cousin = 1 file per domain as no2 above

till 13th August 2010 08:20

Quote:

Originally Posted by Toucan (Post 236351)
This is how it is in debian, ubuntu's cousin = 1 file per domain as no2 above

This file setup is used by ISPConfig on all Linux distributions incl. centos.


All times are GMT +2. The time now is 16:09.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.