HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (
-   Installation/Configuration (
-   -   Get rid of BANNED and VIRUS alert notifications (

datahellas 3rd August 2010 18:41

Get rid of BANNED and VIRUS alert notifications
I use ISPConfig3 with postfix, amavis and clamd. I have set in amavisd.conf messages marked as VIRUS, SPAM and BANNED to be deleted (discard) but I still get email alert notifications. How I can stop getting notifications for such messages?

in amavisd.conf:

$final_virus_destiny = D_DISCARD;
$final_spam_destiny = D_DISCARD;
$final_banned_destiny = D_DISCARD;
$final_bad_header_destiny = D_PASS;

The mail notifications I get have subject like the following:

BANNED contents (.exe,.exe-ms,report.document.doc.exe) in mail FROM [] <>

till 3rd August 2010 18:52

Remove your email address from the banned admin, virus admin and bad header admin fields in the spamfilter policy.

datahellas 3rd August 2010 21:01

Stop getting spam notifications
1 Attachment(s)
I have not entered forward e-mail in my spamfilter policy (see attached screenshot). I checked it for the Normal level which I use globally and for the other spamfilter levels too. All email fields are empty. Why I still get those notifications?

till 3rd August 2010 21:06

I'am not talking about forward fields, I talked abou the admin fields, they are on the other tab.

datahellas 3rd August 2010 21:12

1 Attachment(s)
The "Other" tab is also empty! See attached screenshot.

till 3rd August 2010 21:15

These messages are not sent by a default configuration, so you must have entered your email address somewhere. The only way to activate this in amavisd is to enter the email address in the admin fields. So please check all policys again. If you did any manual modifications to the amavisd configuration files, then check these too if there is your email address somwhere.

datahellas 3rd August 2010 21:28

OK, I found something in amavid.conf but it is the default options. The only thing I changed is the value of the $mydomain variable.

$mydomain = "";

And some lines bellow:

$virus_admin = "virusalert\@$mydomain";
$mailfrom_notify_admin = "virusalert\@$mydomain";
$mailfrom_notify_recip = "virusalert\@$mydomain";
$mailfrom_notify_spamadmin = "spam.police\@$mydomain";
$mailfrom_to_quarantine = ''; # null return path; uses original sender if undef

So, what to do? Comment them? Empty those values? For example set:
$virus_admin = "";

All notifications are mailed to and I get them from a "catch all" e-mail I have. I get about 100 messages per day which is very annoying.

All times are GMT +2. The time now is 03:16.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.