HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (
-   Developers' Forum (
-   -   ISPConfig 3.0.3 Beta 1 ready for testing (

till 28th July 2010 15:30

ISPConfig 3.0.3 Beta 1 ready for testing
The beta version of the upcoming ISPConfig 3.0.3 release is available for downlod. This ISPConfig version is the first beta of the upcoming ISPConfig 3.0.3 series. Beta versions are released for testing purposes, it is not recommended to use them on production systems.



Update instructions


tar xvfz ISPConfig-3.0.3-beta1.tar.gz
cd ispconfig3_install/install
php -q update.php

Enabling the new dashboard module

To enable the new dashboard module for the admin user, click on:

System > CP Users > Edit User, then click on admin, enable the checkbox "dashboard" in the module list and select "dashboard" as Startmodule. Then click on save. Logout from ispconfig and then login again.

xaver 28th July 2010 15:40


looks good!
I tried in SVN awstats and it works fine, but with ruby and webdav i had problems with installtion under debian lenny.
I used some tutorials form howtofroge.
Anywhere a setup guide?


till 28th July 2010 15:43


Anywhere a setup guide?
There are no updated guides available yet beside the guides that you find in the docs folder. To install ruby on debian, just run:


apt-get install libapache2-mod-ruby
/etc/init.d/apache2 restart

xaver 28th July 2010 15:54


i found a bug.
I updatet 1 testsystem. Activatet Domain only Admin .... And i go with the Admin into a Domain. I get a selectbox (no changing as admin) and the box was empty.
I switched back and the input was filled.

And HTML to create a new domain add always a lot of tabs.

till 28th July 2010 16:00

I dont get this behaviour on my servers. I can create and edit websites as admin user without any problems or any empty select fields.


Maybe you had a interface session open during update. Try to logout and then relogin as admin user. Always close the ispconfig interface during update or at least relogin after the update.

xaver 28th July 2010 16:19

Ok the frist Propblem is away -> i changed nothing and i logged out before Oo


Add a new Website:

till 28th July 2010 16:28

Ok. You enabled the domain module on your system which is used to restrict the domain names for clients and admin by a select field but you forgot to add any domains, thats why the select field is empty. So there is no bug, it is the correct behaviour for systems that have the domain module enabled. The domain module is experimental and deactivated by default.

To set your sytsem to the default state again, click on system > interface config > domains and disable the checkbox "Use the domain-module to add new domains".

xaver 28th July 2010 16:35

i added some domains before i did the update

Domain config -> enable -> i cant add Domain -> (2 Screenshoot i logged as Admin)

till 28th July 2010 16:39

You dont have the domain module enabled, so you can not have added any domains. Otherwise it would show up in your menu. To enable the domain module, click on system > cp users > admin and enable the "doamin" module in the modules list. then relogin.

So your question should have been "Where can I add domain names for the domain module" or "How to enable the domain module" and not "i found a bug" ;)

xaver 28th July 2010 16:51

If you use this module, your customers can only select one of the domains the admin creates for them. They can not free edit the domain-field.You have to re-login after changing this value, to make the changes visible.
-> I'm logged as admin (your customers can only select one of the domains the admin creates for them). And i cant change domains as admin. I feel like a customers as admin with this setting.

All times are GMT +2. The time now is 07:58.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.