HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail Debian Lenny (http://www.howtoforge.com/forums/showthread.php?t=47590)

metfan 27th July 2010 17:09

Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail Debian Lenny
 
Hello,

First thanks for the tutorial, , but I have some trouble with it.
I test it 3 times on my server and different VM, but I always have same error.

- 1st:
On page 2 I don't understand (I'm a beginner) which configuration I must use in file /etc/aliases
Code:

postmaster: root
root: postmaster@ks358431.kimsufi.com
clamav: root

- 2nd :
I sent welcome mail but any directory was created.

- 3rd:
according to my log I have trouble with clamav:
Code:

Jul 27 17:00:48 ks358431 postfix/smtp[27947]: 90F2CC12F: to=<ulrich@live-pics.net>, relay=127.0.0.1[127.0.0.1]:10024, delay=7.1, delays=0.02/0/0/7.1, dsn=4.5.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451-4.5.0 Error in processing, id=25888-07, virus_scan FAILED: virus_scan: ALL VIRUS SCANNERS FAILED: ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/run/clamav/clamd.ctl (Can't connect to UNIX socket /var/run/clamav/clamd.ctl: No such file or directory) at (eval 86) line 309.; ClamAV-clamscan av-scanner FAILED: /usr/bin/clamscan unexpected exit 50, output="LibClamAV Warning: *********************************************************** 451-4.5.0 LibClamAV Warning: ***  This version of the ClamAV engine is outdated.    *** 451-4.5.0 LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq *** 451-4.5.0 LibClamAV Warning: *********************************************************** 451-4.5.0 LibClamAV Error: cli_hex2str(): Malformed hexstring: This ClamAV version has reached End of Life! Please upgrade to version 0.95 or later. For more information see  www.clamav.net/eol-clamav-094 and www.clamav.net/download (length: 169) 451-4.5.0 LibClamAV Error: Problem parsing database at line 738 451-4.5.0 LibClamAV Error: Can't load daily.ndb: Malformed database 451-4.5.0 LibClamAV Error: cli_tgzload: Can't load daily.ndb 451-4.5.0 LibClamAV Error: Can't load /var/lib/clamav//daily.cld: Malformed database 451 4.5.0 ERROR: Malformed database" at (eval 86) line 527. (in reply to end of DATA command))
- 4th
when I try to log on squirrelmail I have this error: "ERROR: Connection dropped by IMAP server."
I supposed it's link to my 2nd problem.

I hope some of you will take time to help me.

Thanks

falko 28th July 2010 15:02

Any errors in /var/log/mail.log?

Regarding the ClamAV error: add
Code:

deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
to /etc/apt/sources.list and run
Code:

apt-get update

apt-get install clamav clamav-daemon


metfan 30th July 2010 10:37

Hello,

Thanks for info, clamav is working weel now.

I didn't reply because I stayed update of DNS.
Unfortunately, I have again one problem: 'alias database loop for postmaster'

this is my mail.log:
Quote:

Jul 30 10:35:34 ks358431 postfix/pickup[1471]: 9C80ABFB9: uid=0 from=<root>
Jul 30 10:35:34 ks358431 postfix/cleanup[1877]: 9C80ABFB9: message-id=<20100730083534.9C80ABFB9@ks358431.kimsufi.com>
Jul 30 10:35:34 ks358431 postfix/qmgr[1472]: 9C80ABFB9: from=<root@ks358431.kimsufi.com>, size=320, nrcpt=1 (queue active)
Jul 30 10:35:41 ks358431 postfix/smtpd[1886]: connect from localhost.localdomain[127.0.0.1]
Jul 30 10:35:41 ks358431 postfix/smtpd[1886]: 06BD0BFB7: client=localhost.localdomain[127.0.0.1]
Jul 30 10:35:41 ks358431 postfix/cleanup[1877]: 06BD0BFB7: message-id=<20100730083534.9C80ABFB9@ks358431.kimsufi.com>
Jul 30 10:35:41 ks358431 postfix/qmgr[1472]: 06BD0BFB7: from=<root@ks358431.kimsufi.com>, size=797, nrcpt=1 (queue active)
Jul 30 10:35:41 ks358431 postfix/smtpd[1886]: disconnect from localhost.localdomain[127.0.0.1]
Jul 30 10:35:41 ks358431 amavis[6977]: (06977-20) Passed CLEAN, <root@ks358431.kimsufi.com> -> <ulrich@live-pics.net>, Message-ID: <20100730083534.9C80ABFB9@ks358431.kimsufi.com>, mail_id: CYmfMQdOaB6q, Hits: -0.001, size: 320, queued_as: 06BD0BFB7, 6383 ms
Jul 30 10:35:41 ks358431 postfix/smtp[1880]: 9C80ABFB9: to=<ulrich@live-pics.net>, relay=127.0.0.1[127.0.0.1]:10024, delay=6.4, delays=0.02/0/0/6.4, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=06977-20, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 06BD0BFB7)
Jul 30 10:35:41 ks358431 postfix/qmgr[1472]: 9C80ABFB9: removed
Jul 30 10:35:41 ks358431 postfix/smtp[1890]: 06BD0BFB7: to=<ulrich@live-pics.net>, relay=none, delay=0.01, delays=0/0.01/0/0, dsn=5.4.6, status=bounced (mail for mail.live-pics.net loops back to myself)
Jul 30 10:35:41 ks358431 postfix/cleanup[1877]: 0B82BBFBA: message-id=<20100730083541.0B82BBFBA@ks358431.kimsufi.com>
Jul 30 10:35:41 ks358431 postfix/qmgr[1472]: 0B82BBFBA: from=<>, size=2701, nrcpt=1 (queue active)
Jul 30 10:35:41 ks358431 postfix/bounce[1891]: 06BD0BFB7: sender non-delivery notification: 0B82BBFBA
Jul 30 10:35:41 ks358431 postfix/qmgr[1472]: 06BD0BFB7: removed
Jul 30 10:35:41 ks358431 postfix/local[1892]: warning: alias database loop for postmaster
Jul 30 10:35:41 ks358431 postfix/local[1892]: 0B82BBFBA: to=<postmaster@ks358431.kimsufi.com>, orig_to=<root@ks358431.kimsufi.com>, relay=local, delay=0.02, delays=0/0.01/0/0.02, dsn=5.4.6, status=bounced (alias database loop for postmaster)
Jul 30 10:35:41 ks358431 postfix/qmgr[1472]: 0B82BBFBA: removed
Thanks for your help.

falko 31st July 2010 13:19

Quote:

Jul 30 10:35:41 ks358431 postfix/smtp[1890]: 06BD0BFB7: to=<ulrich@live-pics.net>, relay=none, delay=0.01, delays=0/0.01/0/0, dsn=5.4.6, status=bounced (mail for mail.live-pics.net loops back to myself)
First you should add mail.live-pics.net to the mydestination line in /etc/postfix/main.cf.

Quote:

Jul 30 10:35:41 ks358431 postfix/local[1892]: warning: alias database loop for postmaster
Please post your /etc/aliases file.

metfan 1st August 2010 14:05

Hello,

Do I need to add mail.domain.tld on postfix destination to all domaine name I will setup a mail?

I spoted my aliases file on first post.
Quote:

# /etc/aliases
mailer-daemon: postmaster
postmaster: root
nobody: root
hostmaster: root
usenet: root
news: root
webmaster: root
www: root
ftp: root
abuse: root
noc: root
security: root
root: postmaster@ks358431.kimsufi.com
clamav: root

falko 2nd August 2010 14:02

Quote:

Originally Posted by metfan (Post 235326)
Hello,

Do I need to add mail.domain.tld on postfix destination to all domaine name I will setup a mail?

No.

Quote:

Originally Posted by metfan (Post 235326)
I spoted my aliases file on first post.

Is postmaster@ks358431.kimsufi.com a local account, or is it on a remote mailserver?

metfan 2nd August 2010 14:12

-> If I don't need to put mail.domain.tld for all domain i will setup a mail service, why I need to add mail.live-pics.net ?

-> oups, as I said in my first post, I didn't understand configuration of /etc/aliases file. postmaster@ks358431.kimsufi.com is neither a local account nor remote mail server. ks358431.kimsufi.com is name of my server. Do I must replace postmaster by root or user postfix?

Thanks

falko 3rd August 2010 17:59

Quote:

Originally Posted by metfan (Post 235396)
ks358431.kimsufi.com is name of my server.

Then it is a local account, and you have created a mail loop (the mails will go to postmaster, then to root, then to postmaster again, and so on). Please use another email address.

metfan 4th August 2010 10:41

I tried to replace postmaster@ks358431.kimsufi.com by ulrich@live-pics.net but as I thank, it failed.

I replaced postmaster@ks358431.kimsufi.com but vmail@ks358431.kimsufi.com.
vmail is a user on server, we created this user on your howto.
And it seems to be OK:
Quote:

Aug 4 10:31:19 ks358431 amavis[22120]: (22120-16) Passed CLEAN, <root@ks358431.kimsufi.com> -> <ulrich@live-pics.net>, Message-ID: <20100804083117.98424BFBF@ks358431.kimsufi.com>, mail_id: VHQNgeZC+tJv, Hits: 2.098, size: 302, queued_as: 5D676BFBE, 1765 ms
Aug 4 10:31:19 ks358431 postfix/qmgr[32278]: 5D676BFBE: removed
Aug 4 10:31:19 ks358431 postfix/local[32384]: 5EC63BFC1: to=<vmail@ks358431.kimsufi.com>, orig_to=<root@ks358431.kimsufi.com>, relay=local, delay=0, delays=0/0/0/0, dsn=2.0.0, status=sent (delivered to mailbox)
Aug 4 10:31:19 ks358431 postfix/qmgr[32278]: 5EC63BFC1: removed
But nothing happened in /home/vmail/ and I always have this error "ERROR: Connection dropped by IMAP server" when I logging to squirel.

damn, it's not easy to understand an howto when we are a beginner :(

falko 5th August 2010 15:04

Quote:

Originally Posted by metfan (Post 235536)
I tried to replace postmaster@ks358431.kimsufi.com by ulrich@live-pics.net but as I thank, it failed.

Did you run
Code:

newaliases
afterwards and restart Postfix?

Quote:

I always have this error "ERROR: Connection dropped by IMAP server" when I logging to squirel.
Any errors in your mail log?


All times are GMT +2. The time now is 01:18.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.