HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Problems with wordpress on new server running ISPConfig 3 (http://www.howtoforge.com/forums/showthread.php?t=47564)

ashleykaryl 26th July 2010 17:05

Problems with wordpress on new server running ISPConfig 3
 
Earlier in the month I migrated my sites to a new server ditching cPanel in favour of ISPConfig 3 with the help of a server manager. On the whole it has been pretty smooth sailing with the exception of a wordpress blog that started to give numerous permissions related errors so after a few late nights I decided to ditch the existing blog and start from scratch.

This morning I did a clean install of Wordpress and I can see the standard Wordpress page online at http://www.nudephotopro.com/blog/. Going inside though to perform the first action of deleting the "Hello Dolly" I receive a message:

"Plugin could not be deleted due to an error: Could not fully remove the plugin(s) hello.php."

Examining the file using my FTP client, I see permissions are set at 644 and if I try to change it permission is denied. It seems clear there is some kind of fundamental error in place here but not being very savvy with Wordpress or servers I am unsure what is going on and wondered if somebody here might know what is causing this? No doubt there will just be many more errors if I try to carry on like this.

Thanks

Ashley
PS The database was installed as my user.

BorderAmigos 26th July 2010 21:46

ISPConfig 3 names groups and users as 'clientx' and 'webx' by default (web1 client1, web2 client2, etc). Your user and group names and permissions may not have been changed when you moved over. Check everything under the web directory and make sure these are corrected.

ashleykaryl 26th July 2010 22:09

I went and checked on this via FTP at root a couple hours ago and discovered it was all listed as belonging to root, which was strange because it was installed for a specific user. Now I've changed it to reflect the user and site etc. it seems to be working much better and I was able to make some changes.

There are still a few points I need to work though like just receiving a message saying that I need create a .htaccess file for the permalinks to work and again saying I haven't allowed permission. I'll work that one out somehow.

BorderAmigos 26th July 2010 22:20

The site may have been created for a different user but when you copied the files were you logged in as root?

ashleykaryl 26th July 2010 22:24

ignore this message

ashleykaryl 26th July 2010 22:25

Quote:

Originally Posted by BorderAmigos (Post 234767)
The site may have been created for a different user but when you copied the files were you logged in as root?

Yes I may well have been logged in at root when the wordpress files were uploaded. I didn't know that could have any effect.

The first time I tried this I was logged in at root and created the database for a user, which all looked correct, but the problem of permissions was there. After finding these permissions limitations, I deleted the database and created a new one with the same name while logged in as that user but the permissions were still all listed as being owned by root until I changed them myself using the FTP program.

jumba 26th July 2010 23:48

Take a look here.
For suEXEC and FastCGI to work, you have to disable PHP globally like Falko says on page 2. For suPHP, follow his advice from page 3.
After that, set your website to use suEXEC and FastCGI.
This solves the permission problems. It should be part of the howto.

ashleykaryl 27th July 2010 15:53

The server was all set up for me by a server manager who I haven't seen for a while now. Thanks for the link and I'll have to look into all of this to make sure everything works properly.

When I go to look at the MySql databases via FTP at root I am only seeing one in there, though there are supposed to be three on the server and they are all working as far as I can tell but I am not sure right now where they are located. The one I set up yesterday for example doesn't seem to be there but I know it is active and working.

Toucan 27th July 2010 18:20

If one of the perfect server guides was followed you should have phpmyadmin

Http://yourip/phpmyadmin

kwickcut 28th July 2010 02:28

www.urip.com:8080/phpmyadmin

but check out this post

http://wordpress.org/support/topic/p...-pagebut-in-db


All times are GMT +2. The time now is 10:39.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.