HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 9.10) (http://www.howtoforge.com/forums/showthread.php?t=47417)

superman 19th July 2010 14:19

Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 9.10)
 
Hi there.

I used the howto Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 9.10) and all is working, well almost all.

transport is not working.

I am try to send mail for one domain through the server. I added the domain to the transport table in the mysql database, but I am getting the following error in the logs


Jul 5 11:18:29 zippy postfix/smtpd[9807]: NOQUEUE: reject: RCPT from smtp.***.com[196.*.*.*]: 554 5.7.1 <grant@cdomain.com>: Relay access denied; from=<riaan@bla.com> to=<grant@domain.com> proto=ESMTP helo=<smtp.***.com>


here is my
postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = amavis:[127.0.0.1]:10024
html_directory = /usr/share/doc/postfix/html
inet_interfaces = all
mailbox_size_limit = 0
mydestination = zippy.****.com, localhost, localhost.localdomain
myhostname = zippy.cpassist.co.za
mynetworks = 127.0.0.0/8
myorigin = /etc/mailname
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
readme_directory = /usr/share/doc/postfix
receive_override_options = no_address_mappings
recipient_delimiter = +
relayhost =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_recipient_limit = 10
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /home/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_uid_maps = static:5000

any help will be great

falko 20th July 2010 14:58

Did you restart Postfix?

superman 22nd July 2010 12:41

Yes I have restarted the server.

I added the domain to the transport table
domain.com smtp:[19.*.*.*]

Is there any other place where I should add the domain.com to enable it to forward mail for domain.com to smtp:[19.*.*.*]?

Many thanks for the help

Superman

falko 23rd July 2010 14:33

You might have to add the domain to relay_recipient_maps: http://www.postfix.org/postconf.5.ht...recipient_maps


All times are GMT +2. The time now is 22:24.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.