HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Mysql on openSUSE 11.2 (i586) (http://www.howtoforge.com/forums/showthread.php?t=47350)

Gert-jan 15th July 2010 17:06

Mysql on openSUSE 11.2 (i586)
 
Hi there,

I've a question:

I've installed Mysql (with YAST), but when i now want to start mysql i get an error:


Restarting service MySQL
Shutting down service MySQL done
Will update MySQL now, if you encounter any problems, please read following file:
/usr/share/doc/packages/mysql/README.SuSE
Running protected MySQL...
error: /var/run/mysql/protected/mysql.sock file didn't appeared...



I tried a lot but i don't know what to do now.
Can anyone help me?

greetz,

Gert-jan

Mark_NL 16th July 2010 11:27

Is this mysql an upgrade or a fresh installation?

Gert-jan 16th July 2010 11:33

Mysql was already on that server and it worked.

but with some problems with the database, we've desided to remove mysql and reinstall it.......
And now it won't work......:mad:

Mark_NL 16th July 2010 11:57

Hmm make sure mysql is REALLY removed, don't upgrade OVER the old one, remove the old one first, then install the new version. should do the trick..

i'm reading a lot of threads and it always comes down to ppl who upgrade over the old one, instead of removing it first.


i assume the dir /var/run/mysql/protected/ exists?

what's the mysql socket location defined in your my.cnf?

Gert-jan 16th July 2010 12:04

Hi Mark,

First of all, thans for taking some time for me!

I've looked, and the dir /var/run/mysql/protected/ exists!
(It's an empty dir)

a part of the my.cnf (/etc/my.cnf):
-------------------------------------
[client]
#password = your_password
port = 3306
socket = /var/run/mysql/protected/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port = 3306
socket = /var/run/mysql/protected/mysql.sock
skip-locking
key_buffer_size = 16K
max_allowed_packet = 1M
table_open_cache = 4
sort_buffer_size = 64K
read_buffer_size = 256K
read_rnd_buffer_size = 256K
net_buffer_length = 2K
thread_stack = 128K
-----------------------------------------------



I re-installed mysql with yast.

First removed mysql and mysql client with yast, then rebooted the server, and then reinstalled mysql with yast.....

Mark_NL 16th July 2010 13:25

What user runs the mysqld process? is that user allowed to write in /var/run/mysql/protected ?

Code:

ps flax | grep mysql
grep mysql /etc/passwd
ls -al /var/run/mysql/protected



All times are GMT +2. The time now is 15:44.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.