HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Can't set up root password on MySQL server for Ubuntu 6.06 (http://www.howtoforge.com/forums/showthread.php?t=4707)

simianstyle 5th June 2006 11:05

Can't set up root password on MySQL server for Ubuntu 6.06
 
I've been following the Ubuntu 6.06 "perfect setup" tutorial word for word - and yet the MySQL part doesn't seem to work for me. Whenever i try and set the password at this point:
Code:

mysqladmin -h transit.example.com -u root password yourrootsqlpassword
I always get the error:

Code:

mysqladmin: connect to server at 'transit.example.com' failed
error: 'Host 'transit.example.com' is not allowed to connect to this MySQL server'

As you can tell, instead of calling my server "server1", i've decided to call it "transit". The static IP of the server within my network is 192.168.1.102, and i've set the root sql password already in this step:

Code:

mysqladmin -u root password yourrootsqlpassword
It's obviously somethign other than "yourrootsqlpassword", but when i try and connect to my server - it won't allow me. I'm doing this all on the local machine (not using PuTTY or anything), and instead of the Ubuntu server edition - i'm using the desktop edition (although it should still work the same for both).

I'd appreciate any help resolving this issue. Thanks.

till 5th June 2006 11:56

Dont worry about that error. Proceed with the other steps and when you are finished, install the phpmyadmin pacakge in ISPConfig and check that there are no empty root passwords in the mysql user table.

falko 5th June 2006 14:07

Also make sure that MySQL is listening on all interfaces and that your hostname is really transit.example.com.

simianstyle 5th June 2006 15:48

Well i finished the installation, and got everything up and running with ISPConfig. However when i navigate to the user table in the MySQL database via PHPMyAdmin, there is an empty root password. This is what i see:

http://img216.imageshack.us/img216/9...shot3be.th.png

I think i might've messed up somewhere because there are two root users, but only one of them have a password. I'm very new to all of this - so an advice on what i should do at this point would be greatly appreciated.

till 5th June 2006 15:59

Thats OK. One root user account is for login from localhost, the other is for login from host "transit".

Just edit the root user record with the empty password, enter you password in the password field and select "PASSWORD" in the function field to encrypt your password.

To edit the password on the shell, you might try this:

Quote:

mysqladmin -h transit -u root password yourrootsqlpassword

simianstyle 5th June 2006 16:17

That works perfectly Till, thanks for your help!

domino 15th June 2006 06:58

Hi,

This is really strange. No matter if I user server1, server1.mydomaon.com, or localhost, i get the same error whe trying to set the password.
Code:

mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'

I can not go any further in ISPConfig installation without the correct password, which have not been set. If I enter a blank pssword in ISPConfig setup it still gives me this error.
Code:

Please enter your MySQL password:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
The provided MySQL password is wrong!


glennb 15th June 2006 14:25

I also get the same error as the OP, and I can't work out a way around it.
Having completed the install, I can reach the server on (e.g.)

https://<ipaddress>:81

and I get the login screen, but I am not able to login with a blank password, or with the password I tried to set.

Can anyone give this mysql newbie a clue how to proceed?

Thanks,

Glenn.

falko 15th June 2006 15:35

@domino: What commands exactly did you run that gave you these errors?

@glennb: The defaulr login after the initial ISPConfig installation is username admin, password admin, as described here: http://www.ispconfig.org/manual_installation.htm :)

glennb 15th June 2006 23:47

Quote:

Originally Posted by falko@glennb: The defaulr login after the initial ISPConfig installation is username [I
admin[/I], password admin, as described here: http://www.ispconfig.org/manual_installation.htm :)

Ouch. Now I feel dumb.:o

I can login fine now, thanks. A few DNS wrinkles to iron out, but looking good!

I'm off to read the manual before asking any more stupid questions.

Thanks,

glenn.


All times are GMT +2. The time now is 21:44.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.