HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Postfix not receive but send mail !!! (http://www.howtoforge.com/forums/showthread.php?t=47015)

mixian 5th July 2010 15:25

Postfix not receive but send mail !!!
 
Hi,
i have installed succesfully ispConfig 3.
I'm very happy...dns server, slave with mydnsconfig, synchro, etc...

I' have installed Postfix with Roundcube.
I' have unblocked my firewall ports (110,143,993,995) on my amazon elastic fox interface.
I'm able to send correctly all mail but i not receive from any host.

I'have correctely configured DNS service on MX field and the dig command point to correct IP address.

I note that in the default folder of COURIER DAEMON any mail is present:

/var/vmail/DOMAIN/ACCOUNT/new

and in the log any message of error is present and any mail return to sender.

I try to sen mail from QMAIL server (my other server with plesk) and the mail return with this message:

"This address no longer accepts mail"

I do not understand what's the problem....postfix configuration ? IspConfig? Roundcube? Courier daemon conlict ?

I use imapd and pop3d both ? But interest is only for pop3.

Thanks.

till 5th July 2010 16:46

Please post the exact error messages from the mail log.

mixian 5th July 2010 17:42

hi,
i try to send from rondcube (mixian.it to gmail.com) and i see in the log...but the response in not present in the log...

Jul 5 17:30:52 ns1 amavis[835]: (00835-05) Passed CLEAN, <info@mixian.it> -> <mixian@gmail.com>, Message-ID: <8394cf32187c61e3e104a844fd5deb8d@localhost>, mail_id: 9ten4MHYkxPo, Hits: 2.357, size: 746, queued_as: E2B618E6DB, 573 ms
Jul 5 17:30:52 ns1 postfix/smtp[20712]: 5623B8E6E3: to=<mixian@gmail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.7, delays=0.11/0.01/0/0.58, dsn=2.0.0, status=sent
(250 2.0.0 Ok, id=00835-05, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as E2B618E6DB)
Jul 5 17:30:52 ns1 postfix/smtpd[20715]: disconnect from localhost.localdomain[127.0.0.1]
Jul 5 17:30:52 ns1 postfix/qmgr[16167]: 5623B8E6E3: removed
Jul 5 17:30:53 ns1 postfix/qmgr[16167]: E2B618E6DB: from=<info@mixian.it>, size=1188, nrcpt=1 (queue active)
Jul 5 17:30:53 ns1 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 5 17:30:53 ns1 imapd: LOGIN, user=info@mixian.it, ip=[::ffff:127.0.0.1], port=[50110], protocol=IMAP
Jul 5 17:30:53 ns1 imapd: LOGOUT, user=info@mixian.it, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=10, sent=83, time=0
Jul 5 17:30:53 ns1 postfix/smtp[20718]: E2B618E6DB: to=<mixian@gmail.com>, relay=gmail-smtp-in.l.google.com[74.125.77.27]:25, delay=1, delays=0.06/0.02/0.27/0.65, dsn=2.0.0, status=sent (250 2.0.0 OK 1278343853 a59si10461500eei.16)
Jul 5 17:30:53 ns1 postfix/qmgr[16167]: E2B618E6DB: removed
Jul 5 17:31:42 ns1 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 5 17:31:42 ns1 imapd: LOGIN, user=info@mixian.it, ip=[::ffff:127.0.0.1], port=[50111], protocol=IMAP
Jul 5 17:31:42 ns1 imapd: LOGOUT, user=info@mixian.it, ip=[::ffff:127.0.0.1], headers=232, body=0, rcvd=288, sent=940, time=0
Jul 5 17:31:53 ns1 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 5 17:31:53 ns1 imapd: LOGIN, user=info@mixian.it, ip=[::ffff:127.0.0.1], port=[50113], protocol=IMAP
Jul 5 17:31:53 ns1 imapd: LOGOUT, user=info@mixian.it, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=61, sent=368, time=0
Jul 5 17:32:25 ns1 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 5 17:32:25 ns1 imapd: LOGIN, user=info@mixian.it, ip=[::ffff:127.0.0.1], port=[39496], protocol=IMAP
Jul 5 17:32:25 ns1 imapd: LOGOUT, user=info@mixian.it, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=81, sent=413, time=0
Jul 5 17:32:27 ns1 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 5 17:32:27 ns1 imapd: LOGIN, user=info@mixian.it, ip=[::ffff:127.0.0.1], port=[39498], protocol=IMAP
Jul 5 17:36:38 ns1 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 5 17:36:38 ns1 imapd: LOGIN, user=info@mixian.it, ip=[::ffff:127.0.0.1], port=[39545], protocol=IMAP
Jul 5 17:36:38 ns1 imapd: LOGOUT, user=info@mixian.it, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=56, sent=368, time=0
ns1:/var/www/rcmail/config#

mixian 5th July 2010 20:18

Another think...

if i send a mail from roundcube account to same roundcube account (from same domain that i have crate with ispconfig), i send and receive mail.

I receive mail only if the sender is an local domain / account!

Mark_NL 6th July 2010 10:19

have you opened port 25?

mixian 6th July 2010 11:24

OPS, the learning never ends!
Thanks.

I assumed (wrongly) that port 25 was only for outgoing mail.
SMTP but probably has a different meaning:)

mixian 6th July 2010 12:43

Hi,
i transfer all mail account from /var/vmail/ to /mnt/var/vmail because is more space for massive email.

In the IspConfig panel i have changed two field:

- Mail dir path = /mnt/var/vmail/[domain]/[localpart]
- Home dir = /mnt/var/vmail

is correct or more configuration is necessary because as it seems not to receive any emails ?


Thanks.

till 6th July 2010 12:57

Please undo this. Then stop postfix and courier and run:

mv /var/vmail /var/vmail_old

now mount the new harddiks partition as /var/vmail and move the data back to this partition. There is no need to change any paths.

Mark_NL 6th July 2010 13:03

appendix ;-)

indeed, mount the disc under /var/vmail

(if your new disc is sdb with one partition)

edit /etc/fstab and add the line:

Code:

/dev/sdb1 /var/vmail ext3 defaults 0 0
then: mount /var/vmail

and now move the content of /var/vmail_old to /var/vmail

and you're good to go (no changes to ispconfig needed this way) :)

mixian 6th July 2010 13:08

i try....i not able to work with fstab :)

# Legacy /etc/fstab
# Supplied by: ec2-ami-tools-1.3-45758

/dev/sda1 / ext3 errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jq fmt=vfsv0 0 1

/dev/sda2 /mnt ext3 defaults 0 0

/dev/sda3 swap swap defaults 0 0

/dev/sda2 /mnt/var/vmail ext3 default 0 0 ############ MY LINE

none /proc proc defaults 0 0
none /sys sysfs defaults 0 0


All times are GMT +2. The time now is 04:39.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.