HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (
-   Installation/Configuration (
-   -   ispconfig 3 and virtual servers (

power_electronic 27th June 2010 20:37

ispconfig 3 and virtual servers

i have server with centos 5.4 and for virtualization use openvz (debian)
1. ftp
2. web
3. mysql
4. mail

im try install ispconfig3 :

Select language (en,de) [en]:

Installation mode (standard,expert) [standard]: expert

Full qualified hostname (FQDN) of the server, eg server1.domain.tld []:

MySQL server hostname [localhost]:

MySQL root username [root]:

MySQL root password []: xxxxxxxxxxx

MySQL database to create [dbispconfig]:

MySQL charset [utf8]:

Shall this server join an existing ISPConfig multiserver setup (y,n) [n]: n

Adding ISPConfig server record to database.

Configure Mail (y,n) [y]: n

Configure Jailkit (y,n) [y]: n

Configure FTP Server (y,n) [y]: n

Configure DNS Server (y,n) [y]: n

Hint: If this server shall run the ispconfig interface, select 'y' in the 'Configure Apache Server' option.

Configure Apache Server (y,n) [y]: y

Configuring Apache
Configuring vlogger
Configuring Apps vhost
Configure Firewall Server (y,n) [y]: y

Configuring Firewall
Install ISPConfig Web-Interface (y,n) [y]: y

Installing ISPConfig
ISPConfig Port [8080]: 13579

Configuring DBServer
Installing Crontab
Restarting web server: apache2 ... waiting .
MySQL Connection problem
Installation completed.
root@web:/home/julius/ispconfig3_install/install# echo $?

but when im try login to ispconfig web panel i get what error :

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/ on line 73

maby anybody have idea thats wrong. many thanks

till 27th June 2010 20:41

The error is in this step:

MySQL server hostname [localhost]:

you have to enter "localhost" here as the installer suggested to you. Every node in a multiserver setup has to run a mysql databse on localhost as ispconfig needs this for caching and replication in the multiserver setup.

power_electronic 27th June 2010 22:04

on database (phpmyadmin) i made change host fropm "" to "%" ant its works greate. thanks

All times are GMT +2. The time now is 07:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.