HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   ISPConfig3 | Welcome message has been sent to the wrong host (http://www.howtoforge.com/forums/showthread.php?t=46712)

Hans 23rd June 2010 09:38

ISPConfig3 | Welcome message has been sent to the wrong host
 
In ISPConfig3 in a multiserver environment, "mailserver1.example.com" has been defined as the default mailserver for a client.
That client has also a maildomain on "mailserver2.example.com" instead on the default mailserver.

After creating a mailbox/email address for the client on mailserver2.example.com, the "Welcome to your email account from ISPConfig3" has not been sent to the mailbox on mailserver2.example.com.
ISPConfig3 sents it to the default mailserver of the client instead.

I've also noticed that the client can login with RoundCube with his new email account on mailserver1.example.com AND mailserver2.example.com as well.
Then i found out that the "Welcome to your email account from ISPConfig3" has been sent to his account on mailserver1.example.com and not mailserver2.example.com as it should be. (The mailbox is in the vmail directory on host mailserver2.example.com, which is correct)

My two questions are:
- Why is the client able to logon on mailserver1.example.com AND mailserver2.example.com (with the same email account)
- Why sents ISPConfig3 the Welcome email to the wrong host.

till 24th June 2010 11:11

Looks as if you have server mirroring enabled, this means that all email accounts get created on the master server and the mirror. This also explains why the email was received only on one server.

Hans 24th June 2010 11:53

Hi Till,

Thanks for your reply.
No, I never enabled anything to mirror from one server to another!

The weird thing is that the maildomain is available on the master (mailserver1.example.com) AND on the slave server (mailserver2.example.com).
This explains why the client can logon to both mailservers.

BUT: this is only the case for 2 new mail domains which are created with ISPConfig 3.0.2.2. (After my last recent upgrade)
The mail domains which are created before this version (ISPConfig 3.0.1.6 - ISPConfig 3.0.2.1) are only on the mailserver where they belong.

I checked every server under "System" > "Server Services".
Every server is active, but every field "Is mirror of Server" shows "-None-"

Because, i'm absolutely sure that i did not enable mirroring, i'm thinking about a bug. What else can it be, any suggestions?
Are you able to reproduce this?

Hans 24th June 2010 19:51

Same maildomain on master and slave server
 
@Till,
This afternoon i did some tests.
I created some mail domains on several ISPConfig3 slave servers. I did that from the ISPConfig3 panel on the master server.

Every time and ons every single ISPConfig3 slave server, the mail domains and the mailboxes in it where created correctly.

The problem is that these maildomains and mailboxes where ALSO created on the master ISPConfig3 server, which is NOT correct!

When i delete the maildomain in ISPConfig3 again, ONLY the maildomains on the ISPConfig3 slave servers where deleted. NOT the ones on the ISPConfig3 master server, which i don't understand either.

I'm using ISPConfig3 since version 3.0.1.6 in a production environment and never had this problem before. I'm sure it started since i use ISPConfig 3.0.2.2. so i think it's a bug in ISPConfig 3.0.2.2.

Can you please have a look at it and can anyone out there confirm if they have the same problem?

If so, i will report my problem as a bug in the bugtracker.

till 25th June 2010 12:40

I guess I know what the problem is. the email accounts are not created by ispconfig on the master, thats why they get deleted only on the slaves. the problem is that postfix on the master has access to all records for all mail servers, so it accepts the emails for the slave as well end then creates a maildir for them. This happens as we had to modify the sql queries in the postfix files to add mirroring support.

To fix this, open the ....mysql...cf files in /etc/postfix (only on the master), each of the files contains a condition string like this:

additional_conditions = and type = 'client' and active = 'y'

at the end of the condition strings, you will have to add a condition that restricts the query to the master server ID, so that it looks like this:

additional_conditions = and type = 'client' and active = 'y' and server_id = 1

(I assume here that you master has the server_id 1, which sould be the case in almost all setups).

Then restart postfix.

Please file a bugreport for this.

Hans 25th June 2010 13:46

Thanks
 
Hi Till,
Thanks for your detailed explanation. I will follow your instructions to solve the problem and yes, later today i will report the bug in the bugtracker.

***EDIT ***
In the mean time, i've added this problem to the bugtacker.

Hans 16th July 2010 10:56

Yesterday, i received a mail from the ISPConfig3 bugtracker to notify me that this bug has been fixed. Thanks for the work! :)


All times are GMT +2. The time now is 18:13.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.