HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Ubuntu Server Postfix setup question (http://www.howtoforge.com/forums/showthread.php?t=46560)

T-Bird McCloy 16th June 2010 01:11

Ubuntu Server Postfix setup question
 
First time poster, and admitted total linux nublet.
I've been googling this for about 2 days now with absolutely no love, and I feel like maybe I'm missing some much larger, extremely important puzzle piece.

The company I work for has a new Bluarc server that needs to be able to send unauthenticated emails and error reports to us and home to the company.
So I've been trying to set up an Ubuntu server with postfix to simply (you'd think) take emails from this storage system and pass them on.
The ONLY information I can enter into the bluarc config screen is an
Quote:

"SMTP Primary Server IP/Name:"
or an
Quote:

"SMTP Server to relay email to"
Every tutorial I've found involves authentication and outgoing security. Can't have that. On the bright side, this server doesn't need to receive anything and can be hidden behind our firewall to avoid spammer abuse.

So far, following the Ubuntu setup instructions I've configured postfix with some basic settings as follows: (replaced our domain with word "ourdomain") main.cf
Quote:

smptpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:$ yadayady
smtp_tls_session_cache_database = bree:$ stuff goes here

myhostname = ubuntuserver.ourdomain.com
myorigin = /etc/mailname
mydestination = ubuntuserver.ourdomain.com, ourdomain.com, localhost.ourdomain.com, localhost, gmail.com
relayhost =
mynetworks = 127.0.0.0/8 10.0.10.0/24 192.168.150.0/24
mailbox_command =
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
home_mailbox = Maildir/
So far to test I've been trying to send an email from this server to my gmail account using telnet localhost 25 from the server.
First it failed with a relay access denied
So I added gmail.com, as you can see, to mydestination, as per some forum I googled.
That changed my relay access denied to a:
Quote:

550 5.1.1 Recipient address rejected: User unknown in local recipient table
If it matters, this ubuntu test server is in the 192 subnet and the bluarc is in the 10.0 subnet but they can ping each other and ports are not blocked between subnets.

It seems like there should be a simple way to get simple functionality working. I'd appreciate any and all help, as my tasks here include many things outside of surfing google and ubuntu forums, and I'd like to get to some other work related activities this week.
THanks again, T.B. McCloy

T-Bird McCloy 16th June 2010 04:43

Question just got easier
 
Hey there prospective helper person!
My question just got many times simpler.
I have this all working now from the local box, (that being the computer that Ubuntu is installed on)
I can email gmail or yahoo address and such.

However, when I telnet into the IP address of that box to test sending an email from a different computer via telnet IPaddress 25, my
rcpt to: person@domain.com still gets rejected with a
Quote:

554 5.7.1 Relay Access Denied
So really... hopefully there is only one thing left to solve.
As before, any help would be maximum appreciative.

falko 16th June 2010 15:08

Any errors in your mail log?

T-Bird McCloy 16th June 2010 20:04

@Falko
 
Thanks for your interest. Yes, I figured out where the mail.log actually was, and here's what it says with specific relation to these remote telnet connections.

Quote:

Jun 15 19:39:33 ubuntu postfix/smtpd[5124]: NOQUEUE: reject: RCPT from remotecomp.ourdomain.com[192.168.150.135]: 554 5.7.1 <address@ourdomain.com>: Relay access denied; from=<address@ourdomain.com> to=<address@ourdomain.com> proto=ESMTP helo=<localhost>
Jun 15 19:44:33 ubuntu postfix/smtpd[5124]: timeout after RCPT from remotecomp.ourdomain.com[192.168.150.135]
Jun 15 19:44:33 ubuntu postfix/smtpd[5124]: disconnect from remotecomp.ourdomain.com[192.168.150.135]
Doesn't seem to provide more useful information.

falko 17th June 2010 17:50

Does this also happen in a normal email client such as Outlook or Thunderbird? Please make sure you enable "Server requires authentication" in your email client.

T-Bird McCloy 17th June 2010 22:01

Fixed!
 
Thanks for your help. It actually turned out all incoming IP addresses had to be in this list. Everything appears to be working now.
Quote:

mynetworks = 127.0.0.0/8 10.0.10.0/24 192.168.150.0/24
Cheers!


All times are GMT +2. The time now is 15:04.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.