HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   PureFTPd + Ubuntu 10.04 + ISPConfig 3 + (ve) (http://www.howtoforge.com/forums/showthread.php?t=46503)

rustydogcreative 11th June 2010 17:55

PureFTPd + Ubuntu 10.04 + ISPConfig 3 + (ve)
 
While searching for a Plesk alternative, I called up MT and they mentioned ISPConfig 3. I'd tried Virtualmin/Webmin/Usermin (about 9 times in 3 days) and there was always SOMETHING wrong with the installation.

I've been able to get ISPConfig 3 installed and working. Only one issue though: PureFTPd. It's not working properly.

I followed the "Perfect Server" tutorial for ISPConfig 3.

I'm pretty sure the issue begins at step 15 where it says "Edit /etc/fstab. Mine looks like this (I added ,usrjquota=aquota.user,grpjquota=aquota.group,jqfm t=vfsv0 to the partition with the mount point /):" Not entirely sure why I'd add that, where I'd add it, etc. I've had issues with mounting anything on this server.

Has anyone successfully installed PureFTPd on Ubuntu 10.04 or on a Media Temple (ve)?

Can someone provide a little insight into exactly what is going wrong?

Here's a snippet of the error I get:

Code:

Setting up pure-ftpd-mysql (1.0.24-1) ...
Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -8 UTF-8 -u 1000 -E -A -b -H -O clf:/var/log/pure-ftpd/transfer.log -B
421 Unable to switch capabilities : Operation not permitted
invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
dpkg: error processing pure-ftpd-mysql (--configure):
 subprocess installed post-installation script returned error exit status 252
Errors were encountered while processing:
 pure-ftpd-mysql
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up pure-ftpd-mysql (1.0.24-1) ...
Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -8 UTF-8 -u 1000 -E -A -b -H -O clf:/var/log/pure-ftpd/transfer.log -B
421 Unable to switch capabilities : Operation not permitted
invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
dpkg: error processing pure-ftpd-mysql (--configure):
 subprocess installed post-installation script returned error exit status 252
Errors were encountered while processing:
 pure-ftpd-mysql


till 11th June 2010 20:39

Your problem are the settings of your openvz / virtuozzo VM which dont allow capability switching. So it's not a general issue from pure-ftpd with Ubuntu Linux. There are two solutions:

a) If you have access to the host system, then enable capabilities for this VM by running this command:

Code:

VPSID=101
for CAP in CHOWN DAC_READ_SEARCH SETGID SETUID NET_BIND_SERVICE NET_ADMIN SYS_CHROOT SYS_NICE CHOWN DAC_READ_SEARCH SETGID SETUID NET_BIND_SERVICE NET_ADMIN SYS_CHROOT SYS_NICE
do
  vzctl set $VPSID --capability ${CAP}:on --save
done


b) If you dont have access to the host system or dont want to enable capabilities, follow this FAQ (it works for ubuntu as well and not just debain):

http://www.faqforge.com/linux/contro...ities-enabled/


Regarding the /etc/fstab question. On a OpenVZ VM the quota is enabled on the host system, so you can skip that step as quota is already enabled on your server.

rustydogcreative 11th June 2010 23:38

Amazing
 
Thank you SO much for pointing me in that direction. Truly a satisfying way to end my week!!

:)

Leonardo Dias 29th August 2010 20:54

Install Pure-Ftpd in Ubunto 10.4
 
Please, I followed the tutorial
http://www.howtoforge.com/virtual-ho...ftpd-and-mysql ubuntu-7.10
and had the following error message

rooot@server1:~# / etc / init.d / pure-ftpd-mysql restart
Restarting ftp server: Running: / usr / sbin / pure-ftpd-mysql-l mysql: / etc / pure-ftpd / db / mysql.conf-l pam -8 UTF-8-AND-A-j-O clf: / var / log / pure-ftpd / transfer.log-u 1000-B
421 Unable to switch capabilities: not permitted Operation

My environment is a virtual server with Ubunto 4.10

Could someone help me fix the fault and perform the installation with success?

till 29th August 2010 21:04

The solution is described in post #2 of this thread. Please be aware that this thread is about ISPConfig, but it should work for the tutorial that you used as well.

plmcomputerservices 10th March 2011 13:19

Please Help Till!
 
Can you please help me? I have installed ISPConfig 3 with Purefptd using these instructions.
http://library.linode.com/web-applic...tu-10.04-lucid

Everything works except for FTP capabilities. I tried Proftpd before reading that it didn't work with ISPConfig 3. Pureftpd isn't working either.

After installing both, I create an FTP user in ISPConfig 3 and then try to access via Filezilla and no dice. My error log doesn't reveal except that it says I'm using the wrong credentials... I receive a 503 error in the FTP client. I did see the welcome message from PureFTPd though...

Thank you.

till 10th March 2011 14:35

Quote:

I did see the welcome message from PureFTPd though...
Ok. Then your problem is not related to the problem in this thread. This thread is about pure-ftpd not starting at all and not about authentication problems.

I've seen in your other thread that you installed a wrong FTP server before instead of following the perfect server guide. This is most likely the resaon for the authentication problems, as there are soem config changes nescessary for pure-ftpd and it is required that pure-ftpd is installed before ispconfig gets installed or the pure-fdtpd logins will fail.

To fiy our setup, please redo the steps to install pure-ftpd that are diescribed in the perfect setup guide, especially the change sin the inetd file are nescessary to ensure that pure-ftpd runs in standalone mode. When you verifies and changed these settings, run a manual ispconfig update and select to recionfigure services.

plmcomputerservices 10th March 2011 16:12

Thank you
 
Ok, I went read through the guide applied these configurations to my PureFTPd config as instructed in the guide...

[...]
STANDALONE_OR_INETD=standalone
[...]
VIRTUALCHROOT=true
[...]



I then performed a manual update of ISP Config and reconfigured services. I noticed PureFTPd while it worked through the update. Then I tried to access via FTP from a newly created user.

Server Website Username

vps.palmettocomputerservices.com barterbrokers.com bailey_billtest

I entered "barterbrokers.com" as the host, and "bailey_billtest" as the username and then the password I made up...

I cannot find my pureftpd log file for ubuntu 10.04 but this is what I read in the Filezilla.

Status: Resolving address of barterbrokers.com
Status: Connecting to 173.255.200.220:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 15:00. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER bailey_billtest
Response: 331 User bailey_billtest OK. Password required
Command: PASS ****
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server
Error: Critical error
Error: Could not connect to server

till 10th March 2011 16:55

Quote:

I cannot find my pureftpd log file for ubuntu 10.04
pure-ftpd messages are logged into syslog.

plmcomputerservices 10th March 2011 17:32

I saw the transfers.log file and it's empty. My guess is that logging is turned off.

I did some research. If you mean /var/log/pure-ftpd/transfer.log I don't see anything. I went to make sure that reporting is turned on but I don't see the syslog directory...

I'm reading http://download.pureftpd.org/pub/pure-ftpd/doc/README

Log messages are sent to the syslog daemon. You can disable logging with
'-f none'.
If you want all FTP messages to be redirected to a file, say /var/log/ftp,
add this line to your /etc/syslog.conf file:

ftp.* /var/log/ftp

Where is there a different syslog in Ubuntu 10.04?


All times are GMT +2. The time now is 18:22.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.