HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   No website folder created. (http://www.howtoforge.com/forums/showthread.php?t=46426)

holykim 7th June 2010 23:40

No website folder created.
 
:(Hi,

I am a Ispconfig 3 user since it's been released. I upgraded my Ispconfig 3 to the new version of 3.0.2.1 and I had no problem with.

I had some test for the remoting framework yesterday and then I found I can not create a new website.

When I created a new website on the Ispconfig panel it seemd ok as a new website appeared on the control panel. However, no website folder created on the server. I tried many times delete and create... but it didn't work.

I am not sure this problem caused by my testing for the remoting framework. I had test for 'create user', 'create dns zone', 'create dns recoreds' and all worked fine. (only problem was 'update user' as it had an error with the function 'username_unique' in 'validate_client.inc.php'. maybe missing primary id value...). I tried with the fuctions below.
client_get($session_id, $client_id)
client_add($session_id, $reseller_id, $params)
client_update($session_id, $reseller_id, $client_id, $params)
dns_zone_add($session_id, $client_id, $params)
dns_a_get($session_id, $primary_id)


Is there anyone to help me?... Please...

Many Thanks.
Harry

holykim 8th June 2010 01:02

Resolved. Thanks
 
I changed Ispconfig to debug mode then found I had exactly the same problem with the link below.

http://www.howtoforge.com/forums/showthread.php?t=44838

I removed bind_plugin.inc.php (/usr/local/ispconfig/server/plugins-enabled/bind_plugin.inc.php) then Ispconfig is now working fine.

Do I need to remove bind from the server? I use mydns as Ispconfig use.:)

Many thanks.
Harry

till 8th June 2010 15:48

If you use mydns, then bind should not be installed on the server.


All times are GMT +2. The time now is 14:35.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.