HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   DNS Problem (http://www.howtoforge.com/forums/showthread.php?t=46335)

kennethwu 4th June 2010 05:51

DNS Problem
 
I dunno why i using my dns server,it cannot resolve names in domains not handled by myself,i only can resolve those handled by myself

till 4th June 2010 07:53

Thst the normal behaviour of mydns, as mydns does not dontain a resolver library. Solution is to install a dns resolver like dnsmasq.

Follow the steps that are described in the chapter "Installing DNSMasq" from here (and only this chapter and not the whole tutorial):

http://www.howtoforge.com/mydns_mydn...on_ubuntu_edgy

kennethwu 4th June 2010 08:28

Thanks,but after i install the DNSMasq still cannot solve the domain,is that the config problem?

till 4th June 2010 08:44

1) Have you reconfigured the mydns.conf file as described?
2) Have you restarted mydns?
3) Post the content of /etc/resolv.conf

kennethwu 4th June 2010 08:53

I have changed that but still not working

nameserver 127.0.0.1
search hkhost.biz
nameserver 203.80.96.10
nameserver 203.80.96.9

falko 5th June 2010 12:33

What's in mydns.conf? What's the output of
Code:

netstat -tap
?

mgillett 14th June 2010 23:18

I have a very similar problem. When I try to bring up my domain name it gets stuck on "resolving host" and then times out. I already switched the name servers over.

When I dig mydomain.com, it yields this:

Code:

root@server1:~# dig mydomain.com

; <<>> DiG 9.7.0-P1 <<>> mydomain.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58715
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;mydomain.com.              IN      A

;; ANSWER SECTION:
mydomain.com.      86400  IN      A      12.345.67.890

;; AUTHORITY SECTION:
mydomain.com.      86400  IN      NS      ns1.nameserver.com.

;; Query time: 1 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Mon Jun 14 17:14:10 2010
;; MSG SIZE  rcvd: 88



This is in my /etc/dnsmasq.conf file:

Code:

no-listen = 127.0.0.1
recursive = 127.0.0.1

I followed all of the directions in the tutorial that was linked earlier in this thread. The contents of my configuration files are exactly what that tutorial suggested.




"Netstat -tap" yields this:

Code:

root@server1:~# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address          Foreign Address        State      PID/Program name
tcp        0      0 localhost.localdo:10024 *:*                    LISTEN      999/amavisd (master
tcp        0      0 localhost.localdo:10025 *:*                    LISTEN      1551/master
tcp        0      0 *:mysql                *:*                    LISTEN      609/mysqld
tcp        0      0 localhost.localdo:spamd *:*                    LISTEN      1003/spamd.pid
tcp        0      0 *:http-alt              *:*                    LISTEN      1644/apache2
tcp        0      0 *:www                  *:*                    LISTEN      1644/apache2
tcp        0      0 *:tproxy                *:*                    LISTEN      1644/apache2
tcp        0      0 *:ftp                  *:*                    LISTEN      1564/pure-ftpd (SER
tcp        0      0 server1.hosting.:domain *:*                    LISTEN      802/named
tcp        0      0 localhost.locald:domain *:*                    LISTEN      802/named
tcp        0      0 *:ssh                  *:*                    LISTEN      583/sshd
tcp        0      0 *:smtp                  *:*                    LISTEN      1551/master
tcp        0      0 localhost.localdoma:953 *:*                    LISTEN      802/named
tcp        0      0 *:https                *:*                    LISTEN      1644/apache2
tcp        0    52 server1.hosting.com:ssh 192.168.1.121:50920    ESTABLISHED 616/sshd: administr
tcp6      0      0 [::]:pop3              [::]:*                  LISTEN      1443/couriertcpd
tcp6      0      0 [::]:imap2              [::]:*                  LISTEN      1409/couriertcpd
tcp6      0      0 [::]:ftp                [::]:*                  LISTEN      1564/pure-ftpd (SER
tcp6      0      0 [::]:domain            [::]:*                  LISTEN      802/named
tcp6      0      0 [::]:ssh                [::]:*                  LISTEN      583/sshd
tcp6      0      0 localhost:953          [::]:*                  LISTEN      802/named
tcp6      0      0 [::]:imaps              [::]:*                  LISTEN      1429/couriertcpd
tcp6      0      0 [::]:pop3s              [::]:*                  LISTEN      1463/couriertcpd
root@server1:~#

Thanks!

mgillett 15th June 2010 02:40

I have a very similar problem. Whenever I go to my domain name, it gets stuck on resolving host and then times out. I entered the correct name servers, and it looks like its forwarding when I do a dig mydomain.com:

Code:

; <<>> DiG 9.7.0-P1 <<>> mydomain.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57100
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;mydomain.com.              IN      A

;; ANSWER SECTION:
mydomain.com.      86400  IN      A      75.###.38.###

;; AUTHORITY SECTION:
mydomain.com.      86400  IN      NS      ns1.nameserver.com.

;; Query time: 1 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Mon Jun 14 20:42:56 2010
;; MSG SIZE  rcvd: 88

root@server1:~#


I followed all the configuration instructions in the tutorial posted above and made the appropriate entries in ISPconfig under DNS and site.


Here is the output of my netstat -tap:
Code:

root@server1:~# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address          Foreign Address        State      PID/Program name
tcp        0      0 localhost.localdo:10024 *:*                    LISTEN      896/amavisd (master
tcp        0      0 localhost.localdo:10025 *:*                    LISTEN      1554/master
tcp        0      0 *:mysql                *:*                    LISTEN      567/mysqld
tcp        0      0 localhost.localdo:spamd *:*                    LISTEN      900/spamd.pid
tcp        0      0 *:http-alt              *:*                    LISTEN      1652/apache2
tcp        0      0 *:www                  *:*                    LISTEN      1652/apache2
tcp        0      0 *:tproxy                *:*                    LISTEN      1652/apache2
tcp        0      0 server1.hosting.:domain *:*                    LISTEN      1945/named
tcp        0      0 localhost.locald:domain *:*                    LISTEN      1945/named
tcp        0      0 *:ftp                  *:*                    LISTEN      1567/pure-ftpd (SER
tcp        0      0 *:ssh                  *:*                    LISTEN      569/sshd 
tcp        0      0 localhost.localdoma:953 *:*                    LISTEN      1945/named
tcp        0      0 *:smtp                  *:*                    LISTEN      1554/master
tcp        0      0 *:https                *:*                    LISTEN      1652/apache2
tcp        0    248 server1.hosting.com:ssh 192.168.1.121:59001    ESTABLISHED 2038/sshd: administ
tcp6      0      0 [::]:pop3              [::]:*                  LISTEN      1446/couriertcpd
tcp6      0      0 [::]:imap2              [::]:*                  LISTEN      1412/couriertcpd
tcp6      0      0 [::]:domain            [::]:*                  LISTEN      1945/named
tcp6      0      0 [::]:ftp                [::]:*                  LISTEN      1567/pure-ftpd (SER
tcp6      0      0 [::]:ssh                [::]:*                  LISTEN      569/sshd 
tcp6      0      0 localhost:953          [::]:*                  LISTEN      1945/named
tcp6      0      0 [::]:imaps              [::]:*                  LISTEN      1432/couriertcpd
tcp6      0      0 [::]:pop3s              [::]:*                  LISTEN      1466/couriertcpd
root@server1:~#





Edit: I also forgot to mention that when I ping my domain name, it does ping my ip address. It never stops pinging it though, and it displays a hostname from my service provider...

I followed the perfect setup guide for ubuntu server 10.04, and everything else seems to be working perfectly. Both ns1.nameserver.com and ns2.nameserver.com point to the same IP address. Is this a problem? I had no problem entering those servers with the registrar.

falko 15th June 2010 15:01

Does www.intodns.com show any problems for your domain?

mgillett 15th June 2010 19:12

Hehe, quite a few:


Quote:

NS records from your nameservers:

NS records got from your nameservers listed at the parent NS are:
Oups! I could not get any nameservers from your nameservers (the ones listed at the parent server). Please verify that they are not lame nameservers and are configured properly.


Mismatched NS records

WARNING: One or more of your nameservers did not return any of your NS records.


DNS servers responded

ERROR: One or more of your nameservers did not respond:
The ones that did not responded are: 75.###.38.###


Multiple Nameservers

ERROR: Looks like you have less than 2 nameservers. According to RFC2182 section 5 you must have at least 3 nameservers, and no more than 7. Having 2 nameservers is also ok by me.




Missing nameservers reported by your nameservers:

You should already know that your NS records at your nameservers are missing, so here it is again:

ns1.nameserver.com.
ns2.nameserver.com.



SOA

SOA record No valid SOA record came back!



MX

MX Records
Oh well, I did not detect any MX records so you probably don't have any and if you know you should have then they may be missing at your nameservers!



WWW
WWW A Record
ERROR: I could not get any A records for www.mydomain.com!

(I only do a cache request, if you recently added a WWW A record, it might not show up here.)

Also... Is the intended behavior for my name servers (ns1.nameserver.com, etc) to point to the default server webpage? When I type in ns1.nameserver.com it gives me this message:

Quote:

It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.


All times are GMT +2. The time now is 11:20.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.