HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   CNAME issue (http://www.howtoforge.com/forums/showthread.php?t=46334)

briandelshasta 3rd June 2010 23:11

CNAME issue
 
Am I missing something here or has the functionality of CNAMEs been reduced in ISPConfig 3 vs ISPConfig 2?

In ISPConfig 2 you could create a CNAME to any fully qualified domain name.
In ISPConfig 3 whatever I specify as the CNAME target gets the respective zone's domain tacked on. For example:

For a zone: example1.com
CNAME host1 www.example2.com

In ISPConfig 2 digging host1.example.com would return the IP for www.example2.com.

In ISPConfig 3 I can only get host1.example.com to reply with www.example2.com.example1.com!

I'm sure this has been addressed before, but I couldn't find any threads...
Any ideas?
Thanks

till 4th June 2010 07:48

Quote:

has the functionality of CNAMEs been reduced in ISPConfig 3 vs ISPConfig 2?
The opposite is the case, the DNS functionality has been extended a lot.

Every FQDN (Fully qualified domain name) has to end with a dot. So the correct record is:

For a zone: example1.com.
CNAME host1 www.example2.com.

and not

For a zone: example1.com
CNAME host1 www.example2.com

briandelshasta 4th June 2010 13:56

Indeed. Thanks.


All times are GMT +2. The time now is 14:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.