HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Multiserver Setup - ERROR: Database... (http://www.howtoforge.com/forums/showthread.php?t=46308)

Rapid2214 2nd June 2010 20:41

Multiserver Setup - ERROR: Database...
 
Hi all,
I having this problem: ERROR: Stopped: Database already contains some tables. On my secoundry server :( .
I type 'y' for 'Shall this server join...' and just hit enter for the default database name.
Worked fine on my Virtual Mechines but in the real world it isn't working :rolleyes:

Thanks in advance,

Marty

PS Primary server is working fine...

till 2nd June 2010 22:39

The error means that there is already a database with that name on the slave server which contains database tables. Please delete that database on the slave before you install ispconfig on it. Also be sure that you have not accidently entered the login details for the master database when you got asked for the local mysql db. The details for the master are asked later after you selected to join a master server.

Rapid2214 2nd June 2010 23:22

Thanks now im getting the following output, note im using a new user called 'remotesys' because i had problems with root remotly, i have granted remotesys all privilges


Adding ISPConfig server record to database.

ERROR: Unable to create database user in master database: ispcsrv2 Error: GRANT command denied to user 'remotesys'@'192.168.11.111' for table 'server'

Rapid2214 3rd June 2010 10:59

Fixed it, the user needed to be able to GRANT:

Code:

mysql> GRANT ALL PRIVILEGES
    -> ON *.*
    -> TO root@192.168.11.111
    -> IDENTIFIED BY 'newpassword'
    -> WITH GRANT OPTION;

Thanks for your help


All times are GMT +2. The time now is 06:55.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.