HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Need help with quota on fedora core 11 (http://www.howtoforge.com/forums/showthread.php?t=46284)

saco721 1st June 2010 16:46

Need help with quota on fedora core 11
 
I am a Linux newbie running Fedora core 11 and having difficulties getting quota to work. Here's what I have done so far:

I do :

Code:

yum install quota
Installs quota fine.

Then I edit fstab :

Quote:

#
# /etc/fstab
# Created by anaconda on Thu Feb 11 10:05:18 2010
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
#
UUID=cfdb7341-115f-4238-990d-3ee95d311e45 /boot ext3 defaults 1 2
/dev/mapper/vg_gizmo-lv_root / ext4 defaults,usrquota,grpquota 1 1
/dev/mapper/vg_gizmo-lv_swap swap swap defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts defaults 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0

Then run :

Code:

touch /aquota.user /aquota.group
chmod 600 /aquota.*
mount -o remount /
quotacheck -avugm
quotaon -avug

The aquota.user and aquota.group files get created.

File system mounts ok.

However when I run quotacheck -avugm I get the following messages :
Quote:

quotacheck: Your kernel probably supports journaled quota but you are not using it. Consider switching to journaled quota to avoid running quotacheck after an unclean shutdown.
quotacheck: Cannot open quotafile //aquota.user: Permission denied
quotacheck: Cannot open quotafile //aquota.group: Permission denied
When I run quotaon -avug I get the following messages :

Quote:

quotaon: Cannot open quotafile //aquota.group: Permission denied
quotaon: Cannot find quota file on / [/dev/mapper/vg_gizmo-lv_root] to turn quotas on/off.
quotaon: Cannot open quotafile //aquota.user: Permission denied
quotaon: Cannot find quota file on / [/dev/mapper/vg_gizmo-lv_root] to turn quotas on/off.
Then I reboot the system.

Nothing is written to aquota.user or aquota.group. And I still get the error messages as above.

To me it seems that there may be a problem with permissions on / file system but i'm not sure what they should be.

Where am I going wrong?

Any ideas / advice would be greatly appreciated. Thanks!

falko 2nd June 2010 18:07

Can you try to set up journaled quota, as described in chapter 7 on http://www.howtoforge.com/perfect-se...ispconfig-2-p3 ?

saco721 6th June 2010 15:33

Hi Falko, I have edited my fstab to use journaled quota as you advised.

I changed fstab to :

Quote:

#
# /etc/fstab
# Created by anaconda on Thu Feb 11 10:05:18 2010
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
#
UUID=cfdb7341-115f-4238-990d-3ee95d311e45 /boot ext3 defaults 1 2
/dev/mapper/vg_gizmo-lv_root / ext4 defaults,usrjquota=aquota.user,grpjquota=aquota.gr oup,jqfmt=vsfv0 1 1
/dev/mapper/vg_gizmo-lv_swap swap swap defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts defaults 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
Then I rebooted system and did :

Code:

touch /aquota.user /aquota.group
chmod 600 /aquota.*
mount -o remount /
quotacheck -avugm
quotaon -avug

quotacheck -avugm returns :

Quote:

quotacheck: WARNING- Quotafile //aquota.user was probably truncated. Cannot save quota settings...

quotacheck: WARNING- Quotafile //aquota.group was probably truncated. Cannot save quota settings...

quotacheck: Scanning /dev/mapper/vg_gizmo-lv_root [/] quotacheck : lstat Cannot stat '//home/Eden/./gvfs' : Permission denied Guess you'd better run fsck first !
exiting...
quotaon -avug returns :

Quote:

quotaon: Cannot find quota file on / [/dev/mapper/vg_gizmo-lv_root] to turn quotas on/off.
quotaon: Cannot find quota file on / [/dev/mapper/vg_gizmo-lv_root] to turn quotas on/off.
Tried rebooting and still get errors.

falko 7th June 2010 13:43

Is it
Code:

/dev/mapper/vg_gizmo-lv_root / ext4 defaults,usrjquota=aquota.user,grpjquota=aquota.gr oup,jqfmt=vsfv0 1 1
?
Should be
Code:

/dev/mapper/vg_gizmo-lv_root / ext4 defaults,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vsfv0 1 1
(without space in aquota.group).

saco721 7th June 2010 13:49

Hi Falko,

Its definately

Code:

/dev/mapper/vg_gizmo-lv_root / ext4 defaults,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vsfv0 1 1
dont know why space appeared in group.


All times are GMT +2. The time now is 19:08.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.