HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   ISPConfig 2 Upgrade (http://www.howtoforge.com/forums/showthread.php?t=46224)

pineapple 30th May 2010 00:19

ISPConfig 2 Upgrade
 
Hello

I upgraded to ISPConfig 2.2.36 on both my test server and then my live server and everything appeared to go well however I have now noticed that I cannot connect to the courier mail server. I can send email but I cannot receive it. I get a connection timed out error.

I have restarted courier successfully and can tracert to my mail server and ISPConfig shows that all services are running fine and port 995 is open. I can even log in and use webmail but I cannot recieve with my mail client.

This is what is written to the mail.log when I send an email to myself and then attempt to receive:

May 30 10:00:16 first postfix/smtpd[31972]: warning: 123.456.789.123 (NB: changed IP): hostname 123.456.789.123.dynamic.rev.aanet.com.au verification failed: Name or service not known
May 30 10:00:16 first postfix/smtpd[31972]: connect from unknown[123.456.789.123]
May 30 10:00:16 first postfix/smtpd[31972]: setting up TLS connection from unknown[123.456.789.123]
May 30 10:00:16 first postfix/smtpd[31972]: Anonymous TLS connection established from unknown[123.456.789.123]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
May 30 10:00:17 first postfix/smtpd[31972]: EE38B3F40D9: client=unknown[123.456.789.123], sasl_method=PLAIN, sasl_username=1_andrew
May 30 10:00:17 first postfix/cleanup[31976]: EE38B3F40D9: message-id=<4C01AA96.2040106@nospam.com.au>
May 30 10:00:17 first postfix/qmgr[14052]: EE38B3F40D9: from=<andrew.walters@nospam.com.au>, size=1419, nrcpt=1 (queue active)
May 30 10:00:17 first postfix/smtpd[31972]: disconnect from unknown[123.456.789.123]
May 30 10:00:17 first postfix/pickup[31405]: C21093F43E7: uid=10001 from=<1_andrew>
May 30 10:00:17 first postfix/cleanup[31976]: C21093F43E7: message-id=<20100530000017.C21093F43E7@first.nospam.com.au >
May 30 10:00:18 first postfix/qmgr[14052]: C21093F43E7: from=<1_andrew@mail.nospam.com.au>, size=384, nrcpt=1 (queue active)
May 30 10:00:18 first postfix/local[31994]: C21093F43E7: to=<admispconfig@localhost.localdomain>, relay=local, delay=0.62, delays=0.47/0.01/0/0.14, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
May 30 10:00:18 first postfix/qmgr[14052]: C21093F43E7: removed
May 30 10:00:29 first postfix/local[31977]: EE38B3F40D9: to=<1_andrew@mail.nospam.com.au>, orig_to=<andrew.walters@nospam.com.au>, relay=local, delay=12, delays=0.44/0.01/0/12, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
May 30 10:00:29 first postfix/qmgr[14052]: EE38B3F40D9: removed


What silly thing have I overlooked?

regards and thanks

Andrew

pineapple 30th May 2010 04:56

ISPConfig 2 upgrade - update
 
Hi all

Just an update to my last post - it seems that I cannot use pop-ssl on 995 anymore but I can receive email on port 110.

Any idea how I can revert back to ssl?

Also, SMTP is not as stable as I thought - now giving everyone time-out issues.

Checking the logs I see some fatal errors:

May 30 12:39:16 first postfix/smtpd[4769]: fatal: file /etc/postfix/main.cf: parameter default_privs: unknown user name value: nobody
May 30 12:39:17 first postfix/master[1206]: warning: process /usr/lib/postfix/smtpd pid 4769 exit status 1
May 30 12:39:17 first postfix/master[1206]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
May 30 12:40:17 first postfix/smtpd[4794]: fatal: file /etc/postfix/main.cf: parameter default_privs: unknown user name value: nobody
May 30 12:40:18 first postfix/master[1206]: warning: process /usr/lib/postfix/smtpd pid 4794 exit status 1
May 30 12:40:18 first postfix/master[1206]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
May 30 12:41:18 first postfix/smtpd[4819]: fatal: file /etc/postfix/main.cf: parameter default_privs: unknown user name value: nobody
May 30 12:41:19 first postfix/master[1206]: warning: process /usr/lib/postfix/smtpd pid 4819 exit status 1
May 30 12:41:19 first postfix/master[1206]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
May 30 12:42:19 first postfix/smtpd[4844]: fatal: file /etc/postfix/main.cf: parameter default_privs: unknown user name value: nobody
May 30 12:42:20 first postfix/master[1206]: warning: process /usr/lib/postfix/smtpd pid 4844 exit status 1
May 30 12:42:20 first postfix/master[1206]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
May 30 12:43:20 first postfix/smtpd[4873]: fatal: file /etc/postfix/main.cf: parameter default_privs: unknown user name value: nobody
May 30 12:43:21 first postfix/master[1206]: warning: process /usr/lib/postfix/smtpd pid 4873 exit status 1
May 30 12:43:21 first postfix/master[1206]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
May 30 12:43:38 first pop3d: Connection, ip=[::ffff:203.171.75.54]
May 30 12:43:39 first pop3d: LOGIN FAILED, user=1_andrew, ip=[::ffff:203.171.75.54]
May 30 12:43:44 first pop3d: LOGIN FAILED, user=1_andrew, ip=[::ffff:203.171.75.54]
May 30 12:43:49 first pop3d: LOGIN FAILED, user=1_andrew, ip=[::ffff:203.171.75.54]
May 30 12:43:54 first pop3d: LOGIN FAILED, user=1_andrew, ip=[::ffff:203.171.75.54]
May 30 12:43:59 first pop3d: LOGIN FAILED, user=1_andrew, ip=[::ffff:203.171.75.54]
May 30 12:44:07 first pop3d: LOGIN FAILED, user=1_andrew, ip=[::ffff:203.171.75.54]
May 30 12:44:12 first pop3d: Disconnected, ip=[::ffff:203.171.75.54]
May 30 12:44:21 first postfix/smtpd[4900]: fatal: file /etc/postfix/main.cf: parameter default_privs: unknown user name value: nobody
May 30 12:44:22 first postfix/master[1206]: warning: process /usr/lib/postfix/smtpd pid 4900 exit status 1
May 30 12:44:22 first postfix/master[1206]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling


On trying to restart postfix I get this error:

Stopping Postfix Mail Transport Agent: postfixpostfix: fatal: file /etc/postfix/main.cf: parameter default_privs: unknown user name value: nobody


I have checked main.cf and there is not parameter "default_privs" or value "nobody".

And in trying to restart saslauthd I get:

first:~# /etc/init.d/saslauthd restart
Stopping SASL Authentication Daemon: saslauthd.
Starting SASL Authentication Daemon: saslauthdinstall: invalid user `root'
.


And in reading Falko's advice to someone else with the default_privs issue I checked ispconfig.log and see a bunch of warnings started popping up this afternoon:

1_loraine:x:10003:10001:Loraine Backman:/var/www/web1/user/1_loraine:/bin/false
30.05.2010 - 12:37:24 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 910: WARNING: could not setquota -u 1_loraine 51200 52224 0 0 -a &> /dev/null
30.05.2010 - 12:37:24 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 910: WARNING: could not setquota -u 1_loraine 51200 52224 0 0 -a &> /dev/null
30.05.2010 - 12:37:24 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 911: WARNING: could not setquota -T -u 1_loraine 604800 604800 -a &> /dev/null
30.05.2010 - 12:37:24 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 911: WARNING: could not setquota -T -u 1_loraine 604800 604800 -a &> /dev/null
30.05.2010 - 12:37:24 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web1/user/1_loraine/.forward
30.05.2010 - 12:37:24 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web1/user/1_loraine/.forward
30.05.2010 - 12:37:24 => INFO - USER:
1_anita:x:10004:10001:Anita Hulm:/var/www/web1/user/1_anita:/bin/false
30.05.2010 - 12:37:24 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 910: setquota -u 1_anita 0 0 0 0 -a &> /dev/null
30.05.2010 - 12:37:24 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 910: setquota -u 1_anita 0 0 0 0 -a &> /dev/null
30.05.2010 - 12:37:24 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 911: setquota -T -u 1_anita 604800 604800 -a &> /dev/null
30.05.2010 - 12:37:24 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 911: setquota -T -u 1_anita 604800 604800 -a &> /dev/null
30.05.2010 - 12:37:24 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web1/user/1_anita/.forward
30.05.2010 - 12:37:24 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web1/user/1_anita/.forward
30.05.2010 - 12:37:24 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1002: WARNING: could not setquota -u 1_test 0 0 0 0 -a &> /dev/null
30.05.2010 - 12:37:24 => INFO - USER:
1_test:x:::::/dev/null
30.05.2010 - 12:37:24 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1002: WARNING: could not setquota -u 1_test 0 0 0 0 -a &> /dev/null
30.05.2010 - 12:37:24 => INFO - USER:
1_test:x:::::/dev/null
30.05.2010 - 12:37:24 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
30.05.2010 - 12:37:24 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
30.05.2010 - 12:37:24 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
30.05.2010 - 12:37:24 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
30.05.2010 - 12:37:26 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
30.05.2010 - 12:37:26 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable
30.05.2010 - 12:37:26 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1268: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
30.05.2010 - 12:37:26 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1268: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
30.05.2010 - 12:37:26 => INFO - HTTPD_SYNTAX_CHECK: suexec
30.05.2010 - 12:37:26 => INFO - HTTPD_SYNTAX_CHECK: suexec
30.05.2010 - 12:37:26 => INFO - HTTPD_SYNTAX_CHECK: suexec
30.05.2010 - 12:37:26 => INFO - HTTPD_SYNTAX_CHECK: suexec
30.05.2010 - 12:37:27 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2667: WARNING: could not . /etc/apache2/envvars && httpd -t &> /dev/null
30.05.2010 - 12:37:27 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2681: httpd syntax seems to contain errors, reloading with old configuration
30.05.2010 - 12:37:27 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2667: WARNING: could not . /etc/apache2/envvars && httpd -t &> /dev/null
30.05.2010 - 12:37:27 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2681: httpd syntax seems to contain errors, reloading with old configuration
30.05.2010 - 12:37:27 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2682: mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf_30-05-10_12-37-27
30.05.2010 - 12:37:27 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2682: WARNING: could not mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf_30-05-10_12-37-27
30.05.2010 - 12:37:27 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2683: mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf~ /etc/apache2/vhosts/Vhosts_ispconfig.conf
30.05.2010 - 12:37:27 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2683: WARNING: could not mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf~ /etc/apache2/vhosts/Vhosts_ispconfig.conf
30.05.2010 - 12:37:27 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 755: WARNING: could not /etc/init.d/apache2 reload &> /dev/null
30.05.2010 - 12:37:27 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 755: WARNING: could not /etc/init.d/apache2 reload &> /dev/null
30.05.2010 - 12:37:28 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 755: WARNING: could not /etc/init.d/postfix stop &> /dev/null
30.05.2010 - 12:37:28 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 755: WARNING: could not /etc/init.d/postfix stop &> /dev/null
30.05.2010 - 12:37:28 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 755: /etc/init.d/postfix start &> /dev/null
30.05.2010 - 12:37:28 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 755: /etc/init.d/postfix start &> /dev/null
30.05.2010 - 12:37:28 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2131: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
30.05.2010 - 12:37:28 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2131: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~



I'm starting to think I screwed up something quite badly during the upgrade somehow.

Andrew

till 30th May 2010 09:44

The ispconfig 2 update does not change the postfix or courier configuration, but maybe a harddisk partition is full.

1) Have you installed updates of your linux distribution too?
2) Please post the output of:

df -h

pineapple 30th May 2010 22:08

I did update and upgrade before running the ISPConfig update.

I can no longer get shell access to my box - Putty comes back with "Server unexpectedly closed network connection". Nor can I FTP to it. I could do both of these things even after the mail issues started.

I can log into ISPConfig and the box is not full:

Filesystem Size Used Avail Use% Mounted
/dev/sda1 49G 6.4G 40G 14% /
tmpfs 256M 0 256M 0% /lib/init/rw
udev 256M 464K 256M 1% /dev
tmpfs 256M 0 256M 0% /dev/shm

and all services are running. I think I might have to do a restore back to before I ran the Debian updates.

Andrew

pineapple 31st May 2010 09:33

Just an update - it seems that some of the services have become corrupted - this is a VPS and I have had the hosting company check it at their end and they rebooted it and got the following:

Starting enhanced syslogd: rsyslogdchown: invalid user: `root:adm'
.
Starting domain name service...: bind9named: user 'bind' unknown
failed!
Starting OpenBSD Secure Shell server: sshdPrivilege separation user sshd does not exist
failed!
Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
Starting Courier authentication services: authdaemond.
Starting Courier IMAP server: imapd.
Starting Courier IMAP-SSL server: imapd-ssl.
Starting Courier POP3 server: pop3d.
Starting Courier POP3-SSL server: pop3d-ssl.
Starting Postfix Mail Transport Agent: postfixpostfix: fatal: file /etc/postfix/main.cf: parameter default_privs: unknown user name value: nobody
failed!
Starting SASL Authentication Daemon: saslauthdinstall: invalid user `root'
.
Starting internet superserver: xinetd.
Starting NTP server: ntpduser "ntp" does not exist failed!
Starting ftp server: proftpd - no such user 'proftpd'
- Fatal: User: Unknown user 'proftpd' on line 71 of '/etc/proftpd/proftpd.conf'
failed!
Starting periodic command scheduler: crond.
Starting web server: apache2install: invalid user `www-data'
apache2: bad user name www-data
failed!
Edit /etc/default/fetchmail to start fetchmail
Starting ISPConfig system...
ispconfig_httpd: bad user name admispconfig
/root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
Could not connect to MySQL server!WARNING: Can't get information about user admispconfig.
ISPConfig system is now up and running!


I can no longer access ISPConfig. I may have to ask them to rebuild the VPS and start over unless anyone has any other ideas before I make the plunge.

regards and thanks.

Andrew

till 31st May 2010 10:00

Looks as if the /etc/passwd or /etc/shadow file is corrupted. Do you have a backup of the system that contains the /etc directory?

pineapple 31st May 2010 13:11

I do have the option to restore from a HyperVM backup (the day before) but am afraid what to over-write and what to leave alone.

pineapple 1st June 2010 09:30

I have managed to restore my system from the backup and everything is working as it should except for ISPConfig. When I went to log in I got the following warnings:

Warning: session_start() [function.session-start]: open(/tmp/sess_7e9e4143e9604155f5bc1f1144a270e4, O_RDWR) failed: Permission denied (13) in /home/admispconfig/ispconfig/web/login.php on line 29

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/admispconfig/ispconfig/web/login.php:29) in /home/admispconfig/ispconfig/web/login.php on line 29


Because I had restored from the backup, ISPConfig was the old version so I decided to update. After running through the setup script I got the following:

All prerequisites are fulfilled.
Here we go...

Connected successfully to db db_ispconfig
mysqldump: Couldn't execute 'show fields from `del_status`': Can't create/write to file '/tmp/#sql_27f2_0.MYI' (Errcode: 13) (1)
cp: cannot stat `customized_templates/*': No such file or directory
Restarting some services...
Shutting down ISPConfig system...
/root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
ISPConfig system stopped!
Starting ISPConfig system...
Syntax error on line 1073 of /root/ispconfig/httpd/conf/httpd.conf:
ServerName takes one argument, The hostname of the server
/root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
No results found!ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.


So now ISPConfig is running but I cannot log in and I don't believe the install completed as I didn't get to the point of building Apache etc.

Any advice would be much appreciated.

regards

Andrew

till 1st June 2010 09:37

Looks as if your /tmp folder is full. Before you try to update again, run alsways

mkdir /root/ispconfig/

pineapple 1st June 2010 11:24

That folder already exists. Do you mean to delete it?


All times are GMT +2. The time now is 23:52.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.