HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   need help with ftplicity (http://www.howtoforge.com/forums/showthread.php?t=46145)

Ovidiu 26th May 2010 20:35

need help with ftplicity
 
I've got ftplicity running according to the how-to from howtoforge and it runs fine. Till now I only had to restore single files, which worked fine with ftplicity fetch, now I need to restore a complete folder with all sub folders.

I played around with it, read the manual but can't figure out how to do that.

can anyone who's using it help me out there?

Btw. I do a monthly full backup and the rest are only differential backups. I basically need a wordpress installation's plugin folder restored as the upgrade of a plugin broke a couple of things. I know when the upgrade was done, so basically restoring the version from 1day before the upgrade should fix it.

I tried something along these lines:

Code:

./ftplicity h1550830 fetch var/www/clients/clientXX/webXX/web/wp-content/plugins/ /root/mike-restore 7D
that gives me:
Quote:

var/www/clients/clientXX/webXX/web/wp-content/plugins/ not found in archive, no files restored.
So obviously I tried this next:
Code:

./ftplicity h1550830 fetch var/www/clients/clientXX/webXX/web/wp-content/plugins /root/mike-restore 7D
notice the missing trailing slash behind the folder name.....

this gives me the same error as above :-(

falko 27th May 2010 14:39

Can you log in to your FTP backup server and check if var/www/clients/clientXX/webXX/web/wp-content/plugins/ exists?

Ovidiu 27th May 2010 16:43

how would I do that? ftplicity encrypts and divides the backup into 5MB packages and without decrypting each of them, I can't tell that...

Besides, I am sure its a syntax problem, if I append a file name to the end of that path it works... I jsut can't type in all the filenames one by one, the restore woudl take ages :-(

Ovidiu 31st May 2010 15:52

SOLVED.
gotta admit, it was my fault. I had misread a line and was trying to restore the wrong client :-(
works jsut as supposed to do...


All times are GMT +2. The time now is 12:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.