HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   DNS Zone files not updateing. (http://www.howtoforge.com/forums/showthread.php?t=45469)

tomg 28th April 2010 18:41

DNS Zone files not updateing.
 
Hi,

I'm running ISPConfig 2.2.35 on Centos 5.4. It has been working fine. Yesterday things looked to be working fine. But now today the zone files for DNS are not getting updated.

If I go in to say DNS Manager and add an "A" record the zone file is not updated. However the record does show in the ISPConfig view. (Even if I log out and log in again).
So from ISPconfig things looks correct but the zone file is missing the "A" record.

If I add a new site with a new domain and I have the "Create DNS" ticked the site is created but no zone file is created.

If I add a new site and an existing domain and "Create DNS" is checked again the site is created but the zone file is not updated.

I have checked the permissions of the directory containing the Zone files and the zone files them selves and they look good to me.

I can't see anything in the ispconfig.log to show what the problem is.

Are there other places I can look to identify the problem.


Tom.

createch 29th April 2010 02:27

Please go to Management > Server Settings > DNS to check whether the following default values are still in effect:

named.conf:
/var/named/chroot/etc/named.conf

Zonefiles Dir.:
/var/named/chroot/var/named

tomg 29th April 2010 08:53

Well the settings are /etc/named.conf and /etc/bind but there are symbolic links the end up in the corrrect place.

It looks like the problem is intermittent. I need to do more research in to when it updates the zone files. It looks to me like delteing a site does not remove the entry from the DNS.

Tom.

till 30th April 2010 10:30

Any errors in the file /home/admispconfig/ispconfig/ispconfig.log?

tomg 30th April 2010 14:28

Quote:

Originally Posted by till (Post 226998)
Any errors in the file /home/admispconfig/ispconfig/ispconfig.log?

No no errors or clues in there. Things seem to be working again now however I have found that if I create a new site the DNS Zone file is updated. However, If I then delete the site it is not removed from the DNS Zone file. (Even after I empty the recyle bin)

t.

falko 1st May 2010 14:52

Quote:

Originally Posted by tomg (Post 227022)
However, If I then delete the site it is not removed from the DNS Zone file. (Even after I empty the recyle bin)

That's how it's supposed to be - deleting a site doesn't necessarily mean you also want to delete the zone. If you want to delete the zone as well, you must do this in the DNS Manager.


All times are GMT +2. The time now is 22:49.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.